aboutsummaryrefslogtreecommitdiffstats
path: root/main/alpine-conf
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2015-12-11 13:35:46 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-14 10:07:07 +0000
commite9298e47f1e8c789cceae86aad690d5da4b0f378 (patch)
tree54412152d54c52e05979badd8658d1e79d7cf809 /main/alpine-conf
parent01e5cc006aa245668481a9e4e994bab9a7d08e6c (diff)
downloadaports-e9298e47f1e8c789cceae86aad690d5da4b0f378.tar.bz2
aports-e9298e47f1e8c789cceae86aad690d5da4b0f378.tar.xz
main/alpine-conf: Change /etc/lbu/lbu.conf permissions to 644. Filesystems creation fixes and description added in setup-disk script.
Diffstat (limited to 'main/alpine-conf')
-rw-r--r--main/alpine-conf/0002-makefile_fix_lbu_conf_perms.patch11
-rw-r--r--main/alpine-conf/0002-setup-disk-fix-fs.patch71
-rw-r--r--main/alpine-conf/APKBUILD16
3 files changed, 94 insertions, 4 deletions
diff --git a/main/alpine-conf/0002-makefile_fix_lbu_conf_perms.patch b/main/alpine-conf/0002-makefile_fix_lbu_conf_perms.patch
new file mode 100644
index 0000000000..ef4ccb771e
--- /dev/null
+++ b/main/alpine-conf/0002-makefile_fix_lbu_conf_perms.patch
@@ -0,0 +1,11 @@
+--- old/Makefile
++++ new/Makefile
+@@ -76,7 +76,7 @@
+ install -m 755 -d $(DESTDIR)/$(PREFIX)/lib
+ install -m 755 $(LIB_FILES) $(DESTDIR)/$(PREFIX)/lib
+ install -m 755 -d $(DESTDIR)/$(sysconfdir)
+- install -m 755 $(ETC_LBU_FILES) $(DESTDIR)/$(sysconfdir)
++ install -m 644 $(ETC_LBU_FILES) $(DESTDIR)/$(sysconfdir)
+
+ uninstall:
+ for i in $(SBIN_FILES); do \
diff --git a/main/alpine-conf/0002-setup-disk-fix-fs.patch b/main/alpine-conf/0002-setup-disk-fix-fs.patch
new file mode 100644
index 0000000000..976aa04633
--- /dev/null
+++ b/main/alpine-conf/0002-setup-disk-fix-fs.patch
@@ -0,0 +1,71 @@
+--- old/setup-disk.in
++++ new/setup-disk.in
+@@ -436,16 +436,17 @@
+
+ # install needed programs
+ init_progs() {
+- local raidpkg=
++ local raidpkg= fs= fstools="e2fsprogs"
+ [ -n "$USE_RAID" ] && raidpkg="mdadm"
+- case $ROOTFS in
+- ext*) fstools=e2fsprogs; mkfs_args="-q";;
+- xfs) fstools=xfsprogs; mkfs_args="-q";;
+- # we need load btrfs module early to avoid the error message:
+- # 'failed to open /dev/btrfs-control'
+- btrfs) fstools=btrfs-progs; mkfs_args=""; modprobe btrfs;;
+- esac
+- apk add --quiet sfdisk e2fsprogs lvm2 $raidpkg syslinux $fstools $@
++ for fs in $BOOTFS $ROOTFS $VARFS; do
++ case $fs in
++ xfs) fstools="$fstools xfsprogs"; modprobe xfs;;
++ # we need load btrfs module early to avoid the error message:
++ # 'failed to open /dev/btrfs-control'
++ btrfs) fstools="$fstools btrfs-progs"; modprobe btrfs;;
++ esac
++ done
++ apk add --quiet sfdisk lvm2 $raidpkg syslinux $fstools $@
+ }
+
+ show_disk_info() {
+@@ -522,7 +523,7 @@
+
+ # set up optional raid and create filesystem on boot device.
+ setup_boot_dev() {
+- local disk= bootdev=
++ local disk= bootdev= mkfs_args="-q"
+ local part=$(for disk in $@; do find_boot_partition $disk; done)
+ set -- $part
+ bootdev=$1
+@@ -540,7 +541,8 @@
+ --metadata=0.90 --quiet --run $@ $missing || return 1
+ bootdev=/dev/md0
+ fi
+- mkfs.$BOOTFS -q $bootdev
++ [ "$BOOTFS" == "btrfs" ] && mkfs_args=""
++ mkfs.$BOOTFS $mkfs_args $bootdev
+ BOOT_DEV="$bootdev"
+ }
+
+@@ -730,7 +732,8 @@
+
+ # setup
+ setup_root() {
+- local root_dev="$1" boot_dev="$2"
++ local root_dev="$1" boot_dev="$2" mkfs_args="-q"
++ [ "$ROOTFS" == "btrfs" ] && mkfs_args=""
+ mkfs.$ROOTFS $mkfs_args "$root_dev"
+ mkdir -p "$SYSROOT"
+ mount -t $ROOTFS $root_dev "$SYSROOT" || return 1
+@@ -917,6 +920,12 @@
+ -s Use SWAPSIZE MB instead of autodetecting swap size (Use 0 to disable swap)
+ -v Be more verbose about what is happening
+
++If BOOTFS, ROOTFS, VARFS are specified, then format a partition with specified
++filesystem. If not specified, the default filesystem is ext4.
++Supported filesystems for
++ boot: ext2, ext3, ext4, btrfs
++ root: ext2, ext3, ext4, btrfs, xfs
++ var: ext2, ext3, ext4, btrfs, xfs
+ __EOF__
+ exit 1
+ }
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 4619989078..6984911191 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=3.2.1
-pkgrel=7
+pkgrel=8
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
arch="all"
@@ -14,6 +14,8 @@ source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.x
0001-setup-bootable-warn-and-fix-kernel-name-change.patch
0001-setup-timezone-fix-use-of-z-option.patch
0001-setup-disk-fix-detection-of-volume-group.patch
+ 0002-makefile_fix_lbu_conf_perms.patch
+ 0002-setup-disk-fix-fs.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -46,18 +48,24 @@ f2da5b6cf6e4f1c1d24b59210b172bd8 0001-setup-disk-add-raid-to-initfs-if-root-is-
bb1acd69593e19a9ab686cf6b790bbdb 0001-setup-disk-fix-btrfs-root.patch
f73ccf7115d83a7230fd124c507e3c5c 0001-setup-bootable-warn-and-fix-kernel-name-change.patch
8a67f0ac0826102dc9dceab34c6e036e 0001-setup-timezone-fix-use-of-z-option.patch
-6d8735a89245a5828760b0db80c19edd 0001-setup-disk-fix-detection-of-volume-group.patch"
+6d8735a89245a5828760b0db80c19edd 0001-setup-disk-fix-detection-of-volume-group.patch
+afb885ce5e0851a052a5678fa7072039 0002-makefile_fix_lbu_conf_perms.patch
+4588eb258315445c6a537e5856f5eff8 0002-setup-disk-fix-fs.patch"
sha256sums="f0e7954bb1a5144f551694acfde818bbad4e42a575e7a8e3a06a777ade7a5d9d alpine-conf-3.2.1.tar.xz
e30d5fc4c1ae6af9673c543427561d027792c1bb26e3901ce954d15689dc66e9 0001-setup-apkrepos-fix-speed-test-of-mirrors.patch
6e532930bc263d004975fe1feac115f17452e9f80b5efb22f538e7ebcbb6636d 0001-setup-disk-add-raid-to-initfs-if-root-is-on-lvm.patch
1ec287f5ec4ca94af1b02067eb3a785e527a7658ed737b28e5f39c437db66625 0001-setup-disk-fix-btrfs-root.patch
8fdde27235e14dc1f0f8ed7edb1f086b792f6be060e329e8c2c59d9064b1ee3f 0001-setup-bootable-warn-and-fix-kernel-name-change.patch
c917e5e1e4f7cf7cb5a0cd9922d7e92654d761fb301977c02866a03f374fd184 0001-setup-timezone-fix-use-of-z-option.patch
-cafb433dc1bef88a645b4c4504b207fb09392d112294219d706ac04984725c8c 0001-setup-disk-fix-detection-of-volume-group.patch"
+cafb433dc1bef88a645b4c4504b207fb09392d112294219d706ac04984725c8c 0001-setup-disk-fix-detection-of-volume-group.patch
+ebcddce2df3bbaf8f807eb9d4a46811c01c4f254e8577fd3b34fc22575e3439f 0002-makefile_fix_lbu_conf_perms.patch
+59e88d552282291c9326f3d0b42761837464e5a6c5d288fb8eea76612df6a1a0 0002-setup-disk-fix-fs.patch"
sha512sums="20c11b134234708d86fe4cc093c4073df3496a43d13994d0df369066afed39a9a3c97cebacdbb6518f212e414c9456c31ee41bd600b3fc29e892448118a7b5e8 alpine-conf-3.2.1.tar.xz
135bd0a0638f14a90d896c31de09eb3aa08cd7b2b1452fa20fdf12d128282c5c9eee5c1d76f7d8b62714f15395f225bf61c9968ad04ff164e64e8924c89abbd6 0001-setup-apkrepos-fix-speed-test-of-mirrors.patch
cd2c1f3adef443edf4473719f1cf4f277336fb59527ba70ed30f1f2c87d3cc63afe55a009b5bb5666ff79784ea8a79730dfb67a37d8e3fd8fe8fd7eb88a564fc 0001-setup-disk-add-raid-to-initfs-if-root-is-on-lvm.patch
0d7e6ce26798ab42bf1e2cbda6421e811e949d427e1ff69210abd950686f5ff0a5d61404db9de160268ae976e768aba74f51814b8a9b6e318c32563f924a3965 0001-setup-disk-fix-btrfs-root.patch
df9c2cec67054390d8e8c81b797cfbf0f1b142faabe389f2adf99094b15642285ad683a875728cfff0f13ebb91b3d16eb1ded2ee889b0f9d29a6d05a2a584b83 0001-setup-bootable-warn-and-fix-kernel-name-change.patch
13062f853d30126d77c5201516d978bf30e154a8efd66b0869c7732550694a49e7ad45d29014242cb51a3917c8e7da6af99e51319792a2e89cb8ff9dd69ea08e 0001-setup-timezone-fix-use-of-z-option.patch
-0aee56acd398d22af0dbee887a15c7bf1529c7c6b23618643078be1bd9db300f1fb1f4a2549cf09f21c29aa19d6510221399442582b8a6525f24a3c2f10c174e 0001-setup-disk-fix-detection-of-volume-group.patch"
+0aee56acd398d22af0dbee887a15c7bf1529c7c6b23618643078be1bd9db300f1fb1f4a2549cf09f21c29aa19d6510221399442582b8a6525f24a3c2f10c174e 0001-setup-disk-fix-detection-of-volume-group.patch
+f24d781f75f1e6fcb7ce5d2351a6fb158eaee11b06fc1d1e73ccb01a22c889b07a0703453259a8e69c8281230527f33b60a3eb217cafff4b15261fb1b4f91044 0002-makefile_fix_lbu_conf_perms.patch
+12f95213dd6ce50089e8428b4cdf72f2e4de1137bd5f85d34a7a52fa0116fb3dfb0abb8989d66db32600cf387fffe7ffb96f6f94dc87b8ae12159ecaa883ae6e 0002-setup-disk-fix-fs.patch"