aboutsummaryrefslogtreecommitdiffstats
path: root/main/alpine-keys
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-04-20 04:25:06 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-20 13:12:05 +0000
commite48f7abd0acaf1d170b01c56f806e6a5632088e6 (patch)
tree6185742daecdbd7d143024ccdf3cfbfb3d1f8855 /main/alpine-keys
parent9993cf9be978a22205ee895a252ed36bd6021e76 (diff)
downloadaports-e48f7abd0acaf1d170b01c56f806e6a5632088e6.tar.bz2
aports-e48f7abd0acaf1d170b01c56f806e6a5632088e6.tar.xz
main/alpine-keys: install key for s390x
Diffstat (limited to 'main/alpine-keys')
-rw-r--r--main/alpine-keys/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/main/alpine-keys/APKBUILD b/main/alpine-keys/APKBUILD
index e5ecec7446..752cb05a2b 100644
--- a/main/alpine-keys/APKBUILD
+++ b/main/alpine-keys/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-keys
pkgver=2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Public keys for Alpine Linux packages"
url="http://alpinelinux.org"
# we install arch specific keys to /etc so we cannot do arch=noarch
@@ -43,19 +43,25 @@ _ins_key() {
_install_x86() {
case "$1" in
- x86*) _ins_key $1 $2 || return 1
+ x86*) _ins_key $1 $2 ;;
esac
}
_install_arm() {
case "$1" in
- aarch64|arm*) _ins_key $1 $2 || return 1;;
+ aarch64|arm*) _ins_key $1 $2 ;;
esac
}
_install_ppc() {
case "$1" in
- ppc*) _ins_key $1 $2 || return 1;;
+ ppc*) _ins_key $1 $2 ;;
+ esac
+}
+
+_install_s390x() {
+ case "$1" in
+ s390x) _ins_key $1 $2 ;;
esac
}
@@ -66,17 +72,17 @@ package() {
_archs="${i%:*}"
_key="${i#*:}"
install -Dm644 "$srcdir"/$_key \
- "$pkgdir"/usr/share/apk/keys/$_key \
- || return 1
+ "$pkgdir"/usr/share/apk/keys/$_key
for _arch in ${_archs//,/ }; do
- mkdir -p "$pkgdir"/usr/share/apk/keys/$_arch || return 1
+ mkdir -p "$pkgdir"/usr/share/apk/keys/$_arch
ln -s ../$_key "$pkgdir"/usr/share/apk/keys/$_arch/
case "$CARCH" in
- x86*) _install_x86 $_arch $_key || return 1;;
- arm*|aarch64) _install_arm $_arch $_key || return 1;;
- ppc*) _install_ppc $_arch $_key || return 1;;
+ x86*) _install_x86 $_arch $_key ;;
+ arm*|aarch64) _install_arm $_arch $_key ;;
+ ppc*) _install_ppc $_arch $_key ;;
+ s390x) _install_s390x $_arch $_key ;;
esac
done
done