aboutsummaryrefslogtreecommitdiffstats
path: root/main/alpine
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-14 09:41:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-14 09:41:47 +0000
commit73cbf1b72f817d729386d4eca4118ffd551f373c (patch)
tree5bb1359bf355190e061d3cb2e398afc5ee9e982a /main/alpine
parent71b477a8f8fa6985aea552ed941e6ea73d43852f (diff)
downloadaports-73cbf1b72f817d729386d4eca4118ffd551f373c.tar.bz2
aports-73cbf1b72f817d729386d4eca4118ffd551f373c.tar.xz
main/alpine: build fix for uclibc
Diffstat (limited to 'main/alpine')
-rw-r--r--main/alpine/APKBUILD21
-rw-r--r--main/alpine/uclibc.patch20
2 files changed, 37 insertions, 4 deletions
diff --git a/main/alpine/APKBUILD b/main/alpine/APKBUILD
index fe37375374..052db5f686 100644
--- a/main/alpine/APKBUILD
+++ b/main/alpine/APKBUILD
@@ -3,13 +3,12 @@ pkgname=alpine
pkgver=2.00_p84
_ver=${pkgver%_p*}
_pver=${pkgver##*_p}
-pkgrel=2
+pkgrel=3
pkgdesc="Text-based email client, friendly for novices but powerful"
url="http://www.washington.edu/alpine/"
arch="all"
license="APACHE"
depends=""
-options="!configsub"
makedepends="openldap-dev heimdal-dev ncurses-dev openssl-dev
automake autoconf libtool"
subpackages="$pkgname-doc"
@@ -18,6 +17,7 @@ source="ftp://ftp.cac.washington.edu/alpine/alpine.tar.bz2
CVE-2008-5514.patch
libcrypt-underlinking.patch
libcrypto-underlinking.patch
+ uclibc.patch
"
_builddir="$srcdir"/$pkgname-$_ver
@@ -32,7 +32,7 @@ prepare() {
esac
done
libtoolize --force && aclocal -I m4 && autoconf \
- && automake --add-missing || return 1
+ && automake --force --add-missing || return 1
}
build() {
@@ -59,4 +59,17 @@ md5sums="84e44cbf71ed674800a5d57eed9c1c52 alpine.tar.bz2
785cea92b11d6655c183f3379468a643 all_p84.patch
1b52a54a656979116c09fb1d948a4325 CVE-2008-5514.patch
c0afe83884124c8945db376e91863a83 libcrypt-underlinking.patch
-1db0d3aad97a0e11c6910234a802264c libcrypto-underlinking.patch"
+1db0d3aad97a0e11c6910234a802264c libcrypto-underlinking.patch
+b31ed2bf31f80b10f19b4771645f3e75 uclibc.patch"
+sha256sums="c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6 alpine.tar.bz2
+3e9441b74b54c829f9ac5cc15a82d311cad003632506247a961aa6b344b6603a all_p84.patch
+07fd3dd2ffdfe9e2c952603b9aae099d1250bc89373de3e1a5009ec5d251346b CVE-2008-5514.patch
+fcffe3ae3a44b03880ac2305c269237f3f50bfe68c70b95d73c099500fd0fcdd libcrypt-underlinking.patch
+5af4fd05b91e0c34182b27f2faafc2c5df4ebffcad1042cc5c3cf2fce783ec07 libcrypto-underlinking.patch
+acf9ddd3b7850b166895373e8c332a35fcece5c1c98af75e24ee1e2033a86c89 uclibc.patch"
+sha512sums="17c6e65fbe767d4f9ffb3d3c2bb3deeab9d3620cd046cbb0009290aa484c9254effa992957631f0603bd82b82aeca2923d391aee6d20a7684d5830fbca8ce4d2 alpine.tar.bz2
+c4cb716c9c39af6319ff0fc9839d049a7e30628d93b110f62a49b0bbeea87ede05b6d0945799d45b2a4793ef6efd330a3a3a58555bb44aef5b656964d0d8d5ae all_p84.patch
+c5ed29171b13eb8edc1a8bde0a9923afcb4809bf17da96bc4c72ce501e016494523b0c184754027f9e5fcfec0f0405354e0ebafd6b8e30b9b4986b85e16e881a CVE-2008-5514.patch
+426a51fc157c81ed2d3b70e478c38c1c8a2625ddaafce052a2d43d0979715fdd27d6d62095a80971287bb5e8a9c67d57b9fd224b37fc42ab716a28fceba928eb libcrypt-underlinking.patch
+f00d2d32b92582c7c8d23393cff10e7a3e3c9e510c4cee3479b059c7641a69ca19948db8c57c422e768fdd6bda2f4e4f50d718579f77d5818a74e523026ef479 libcrypto-underlinking.patch
+f4e4b7e95629c0cc1b07d728bb41a34c76f7a04f1b53c9a4909b62811bb0f0f1717ca78d846f3a17de9376e98daac8245f3f6e42d9f2472da7b569274a3c26b2 uclibc.patch"
diff --git a/main/alpine/uclibc.patch b/main/alpine/uclibc.patch
new file mode 100644
index 0000000000..f4c84fff54
--- /dev/null
+++ b/main/alpine/uclibc.patch
@@ -0,0 +1,20 @@
+--- ./configure.ac.orig 2013-08-14 09:23:19.968703427 +0000
++++ ./configure.ac 2013-08-14 09:24:02.892913484 +0000
+@@ -597,7 +597,7 @@
+ else
+ dnl preload c-client default locations/options
+ case $host in
+- *-linux-gnu)
++ *-linux-gnu|*-linux-uclibc)
+ if test -f /etc/fedora-release -o -f /etc/redhat-release -o -f /etc/redhat_version ; then
+ alpine_SSLTYPE="nopwd"
+ if test -d /etc/pki/tls ; then
+@@ -1271,7 +1271,7 @@
+ dnl build from c-client. Most of this will go away when c-client
+ dnl adopts configure
+ case "$host" in
+- *-linux-gnu*|*-k*bsd*-gnu*)
++ *-linux-gnu*|*-k*bsd*-gnu*|*-linux-uclibc)
+ alpine_path_delim="/"
+ alpine_mode_readonly="(0600)"
+ if test -f /etc/fedora-release ; then