aboutsummaryrefslogtreecommitdiffstats
path: root/main/ansible
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-02-27 17:04:30 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-02-27 17:04:30 +0100
commit70af635d68e71a24e1700fa2e0990390b43dd37a (patch)
treeef7b909de51e72806e6557cbff7bd0e2820c320f /main/ansible
parent1e5d3ba5b91a4b6977131a3b7143584c1ee353e3 (diff)
downloadaports-70af635d68e71a24e1700fa2e0990390b43dd37a.tar.bz2
aports-70af635d68e71a24e1700fa2e0990390b43dd37a.tar.xz
main/ansible: upgrade to 2.0.1.0
Diffstat (limited to 'main/ansible')
-rw-r--r--main/ansible/APKBUILD13
-rw-r--r--main/ansible/iteration-context.patch13
2 files changed, 5 insertions, 21 deletions
diff --git a/main/ansible/APKBUILD b/main/ansible/APKBUILD
index 517a4058b5..44dccbd089 100644
--- a/main/ansible/APKBUILD
+++ b/main/ansible/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=ansible
-pkgver=2.0.0.2
+pkgver=2.0.1.0
pkgrel=1
pkgdesc="A configuration-management, deployment, task-execution, and multinode orchestration framework"
url="http://ansible.com"
@@ -11,7 +11,7 @@ depends="python py-yaml py-paramiko py-jinja2 py-markupsafe"
makedepends="python-dev py-setuptools"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::http://releases.ansible.com/ansible/$pkgname-$pkgver.tar.gz
- iteration-context.patch"
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -49,9 +49,6 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/README.extras.md || return 1
}
-md5sums="816d0c49e084383e47a725c761a0e413 ansible-2.0.0.2.tar.gz
-e745fcea8520d23386d238d249742741 iteration-context.patch"
-sha256sums="27db0b99113fab85b1430c361c7790a0aa7f5c614c9af13362e2adbba07e5828 ansible-2.0.0.2.tar.gz
-bc11f3095ea9b00e2855a6969bce3764137f54114f979e519e299a5584dfde62 iteration-context.patch"
-sha512sums="bf034384849d3f065ff77982e2e47a94727fc2982f0dac8d67efda2646dcdbd52ba9cc3ddfcdb9cd8210af0935f6f42946cc8ddc659d62cccd670e5d55c7dfa0 ansible-2.0.0.2.tar.gz
-30cc45a485a1048b3e86dea8fc30b65095326e79c0b16ab4d9ab0c8362ec3cefe352500b215858c2b150b2d9a288d3e9bca05c1354969bb16ade2ad123b3df83 iteration-context.patch"
+md5sums="84c576762bc1a8a345fe12ac338bd2d8 ansible-2.0.1.0.tar.gz"
+sha256sums="cddc4fa6af4c1be6cd1d6634de1bd0397abad921c76b32cab6722c042744ee5d ansible-2.0.1.0.tar.gz"
+sha512sums="ed126341ddae2be8f55984d7bc8b6232239f59a56f8028f19f8e2ee25096b3bba934b88b2ee72b53bbbdd245ec51a10dfbc3ffed9e0bc9f13444557ff490d6df ansible-2.0.1.0.tar.gz"
diff --git a/main/ansible/iteration-context.patch b/main/ansible/iteration-context.patch
deleted file mode 100644
index db2ed31042..0000000000
--- a/main/ansible/iteration-context.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -upr ansible-2.0.0.2.orig/lib/ansible/executor/task_executor.py ansible-2.0.0.2/lib/ansible/executor/task_executor.py
---- ansible-2.0.0.2.orig/lib/ansible/executor/task_executor.py 2016-02-04 00:51:21.944735819 +0100
-+++ ansible-2.0.0.2/lib/ansible/executor/task_executor.py 2016-02-04 00:52:26.688134310 +0100
-@@ -365,6 +365,9 @@ class TaskExecutor:
- if not self._connection or not getattr(self._connection, 'connected', False):
- self._connection = self._get_connection(variables=variables, templar=templar)
- self._connection.set_host_overrides(host=self._host)
-+ # If connection is reused, its _play_context is no longer valid and needs to be replaced
-+ # This fixes issues with tasks running sudo in a loop and having the success_key incorrect in the second iteration
-+ self._connection._play_context = self._play_context
-
- self._handler = self._get_action_handler(connection=self._connection, templar=templar)
-