aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache-mod-auth-ntlm-winbind
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2010-10-23 19:39:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-24 06:40:00 +0000
commit1893321452cc49e2e1f3e1f851a6b175eacd00ea (patch)
treec2285db95136873ed52a271c6636ae080ffcc9c7 /main/apache-mod-auth-ntlm-winbind
parent5332e1d8959452e0d0afbe96f274aa059050b839 (diff)
downloadaports-1893321452cc49e2e1f3e1f851a6b175eacd00ea.tar.bz2
aports-1893321452cc49e2e1f3e1f851a6b175eacd00ea.tar.xz
main/apache-mod-ntlm-winbind: moved from testing
Diffstat (limited to 'main/apache-mod-auth-ntlm-winbind')
-rw-r--r--main/apache-mod-auth-ntlm-winbind/APKBUILD34
-rw-r--r--main/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf1
2 files changed, 35 insertions, 0 deletions
diff --git a/main/apache-mod-auth-ntlm-winbind/APKBUILD b/main/apache-mod-auth-ntlm-winbind/APKBUILD
new file mode 100644
index 0000000000..1165ddd81e
--- /dev/null
+++ b/main/apache-mod-auth-ntlm-winbind/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=apache-mod-auth-ntlm-winbind
+pkgver=0.1
+pkgrel=1
+pkgdesc="Authentication module for Apache using NTLM protocol with winbind helper"
+url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+license="Apache2"
+depends="apache2 samba winbind"
+makedepends="autoconf apache2-dev apr-util-dev apr-dev"
+source="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/mod_auth_ntlm_winbind.c
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/configure.in
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/Makefile.in
+mod-auth-ntlm-winbind.conf"
+
+build() {
+ cd "$srcdir"
+ autoconf
+ ./configure
+ make DESTDIR="$pkgdir" || return 1
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+ install mod-auth-ntlm-winbind.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-ntlm-winbind.conf
+ install "$srcdir"/.libs/mod_auth_ntlm_winbind.so "$pkgdir"/usr/lib/apache2/mod_auth_ntlm_winbind.so
+}
+
+md5sums="01d32e311e6a404bcf4179c863081818 mod_auth_ntlm_winbind.c
+e1490dae6e468d4bc56154b16e5d8c24 configure.in
+410de8b0ac7ffe5c44a71d094190187d Makefile.in
+331b392c7aaa13b3a9ea8780ce2db3d4 mod-auth-ntlm-winbind.conf"
diff --git a/main/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf b/main/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf
new file mode 100644
index 0000000000..c797f6331b
--- /dev/null
+++ b/main/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf
@@ -0,0 +1 @@
+LoadModule auth_ntlm_winbind_module modules/mod_auth_ntlm_winbind.so