aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache2-mod-wsgi
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-11-26 22:30:43 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 12:19:04 +0000
commit1daed51a515c35cf9a54c740db8e67d8b76d5b90 (patch)
tree579dc408d1047f98e5ac73199a854076349b3110 /main/apache2-mod-wsgi
parent1c339fab9c3b5d19b01ec9a30dfe12aa4442b0ad (diff)
downloadaports-1daed51a515c35cf9a54c740db8e67d8b76d5b90.tar.bz2
aports-1daed51a515c35cf9a54c740db8e67d8b76d5b90.tar.xz
main/apache2-mod-wsgi: upgrade to 4.5.22 and modernize abuild
Diffstat (limited to 'main/apache2-mod-wsgi')
-rw-r--r--main/apache2-mod-wsgi/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/main/apache2-mod-wsgi/APKBUILD b/main/apache2-mod-wsgi/APKBUILD
index af160824b6..9fd9600ee7 100644
--- a/main/apache2-mod-wsgi/APKBUILD
+++ b/main/apache2-mod-wsgi/APKBUILD
@@ -2,38 +2,37 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=apache2-mod-wsgi
_realname=mod_wsgi
-pkgver=4.5.15
+pkgver=4.5.22
pkgrel=0
pkgdesc="Python WSGI Module for Apache2"
url="http://code.google.com/p/modwsgi/"
arch="all"
license="ASL 2.0"
depends="apache2 python2"
-depends_dev=
-makedepends="$depends_dev apache2-dev python2-dev"
-install=""
+makedepends=" apache2-dev python2-dev"
+options="!check" # no tests provided
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/GrahamDumpleton/mod_wsgi/archive/$pkgver.tar.gz
$pkgname.apache2.conf"
-
builddir="$srcdir"/$_realname-$pkgver
+
build() {
cd "$builddir"
CFLAGS="" CXXFLAGS="" CPPFLAGS="" \
./configure --prefix=/usr \
--with-apxs=/usr/bin/apxs \
- --with-python=/usr/bin/python2 || return 1
- make || return 1
+ --with-python=/usr/bin/python2
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir"/$pkgname.apache2.conf \
- "$pkgdir"/etc/apache2/conf.d/wsgi-module.conf || return 1
+ "$pkgdir"/etc/apache2/conf.d/wsgi-module.conf
install -Dm644 LICENSE \
- "$pkgdir"/usr/share/doc/$pkgname/LICENSE || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/LICENSE
}
-sha512sums="35690cb5ef1c8d8a2c071bb8ac08de3dcb2107007b6319b2f01a697334231ce9d222c3ecd49285bc061405a4a2759b24e5140de8fef0bce7cce67936eb99ef45 apache2-mod-wsgi-4.5.15.tar.gz
+sha512sums="68f67602d9c834cbcf5ff42e1e3a1ab71932a0886b9f670f24c5bc0facf541dfbe5b8284d7f90293a53f28826a07fbda874e790b70a9317ec0c720689bdc6a27 apache2-mod-wsgi-4.5.22.tar.gz
5b36a458bd3539e58ea61ec405c4f5c5e0001a644263b0e1f8421a5c7fc7884b6df1355674a9d9b610780b5e9db6ce66d0ae1bbc0e512ecb027c3757209152c8 apache2-mod-wsgi.apache2.conf"