aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache2-mod-wsgi
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-04-28 12:04:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-04-28 12:04:49 +0000
commitede807a3502d571e0e6257ae8e6be609eba5c2f1 (patch)
tree6120e7c8f31c35665cebc3c9b3e714b747c34798 /main/apache2-mod-wsgi
parent69504f3c820d9a32a7824f07ad8f24c0536e44e3 (diff)
downloadaports-ede807a3502d571e0e6257ae8e6be609eba5c2f1.tar.bz2
aports-ede807a3502d571e0e6257ae8e6be609eba5c2f1.tar.xz
main/apache2-mod-wsgi: moved from testing
Diffstat (limited to 'main/apache2-mod-wsgi')
-rw-r--r--main/apache2-mod-wsgi/APKBUILD43
-rw-r--r--main/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf1
-rw-r--r--main/apache2-mod-wsgi/apache2-mod-wsgi.post-install10
3 files changed, 54 insertions, 0 deletions
diff --git a/main/apache2-mod-wsgi/APKBUILD b/main/apache2-mod-wsgi/APKBUILD
new file mode 100644
index 0000000000..39e2babcce
--- /dev/null
+++ b/main/apache2-mod-wsgi/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=apache2-mod-wsgi
+_realname=mod_wsgi
+pkgver=4.4.11
+pkgrel=0
+pkgdesc="Python WSGI Module for Apache2"
+url="http://code.google.com/p/modwsgi/"
+arch="all"
+license="ASL 2.0"
+depends="apache2 python"
+depends_dev=
+makedepends="$depends_dev apache2-dev python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/GrahamDumpleton/mod_wsgi/archive/$pkgver.tar.gz
+ $pkgname.apache2.conf"
+
+_builddir="$srcdir"/$_realname-$pkgver
+build() {
+ cd "$_builddir"
+ CFLAGS="" CXXFLAGS="" CPPFLAGS="" \
+ ./configure --prefix=/usr \
+ --with-apxs=/usr/bin/apxs \
+ --with-python=/usr/bin/python || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 "$srcdir"/$pkgname.apache2.conf \
+ "$pkgdir"/etc/apache2/conf.d/wsgi-module.conf || return 1
+ install -Dm644 LICENSE \
+ "$pkgdir"/usr/share/doc/$pkgname/LICENSE || return 1
+}
+
+md5sums="5d2744cf3f5018b98116af68560c6df5 apache2-mod-wsgi-4.4.11.tar.gz
+e1795e051e7aae1f865fde0d3b86a507 apache2-mod-wsgi.apache2.conf"
+sha256sums="e1d6b95f696af49a334419b60e1271872f8d446027acc481ef5c9c912cbb0328 apache2-mod-wsgi-4.4.11.tar.gz
+8196a509f90fa10b9464d1c58f4a13d558259e863ccc2761ee1e2c2fcd323f45 apache2-mod-wsgi.apache2.conf"
+sha512sums="e264357482ccc13ee4afc2685422b408e82fb8c1caafdb7d606ef5eaf42653861ba0e828370a31ffb5f81358f293a325dc9640ea9bb02548df385a9e27fa605a apache2-mod-wsgi-4.4.11.tar.gz
+5b36a458bd3539e58ea61ec405c4f5c5e0001a644263b0e1f8421a5c7fc7884b6df1355674a9d9b610780b5e9db6ce66d0ae1bbc0e512ecb027c3757209152c8 apache2-mod-wsgi.apache2.conf"
diff --git a/main/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf b/main/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf
new file mode 100644
index 0000000000..19f356756b
--- /dev/null
+++ b/main/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf
@@ -0,0 +1 @@
+LoadModule wsgi_module modules/mod_wsgi.so
diff --git a/main/apache2-mod-wsgi/apache2-mod-wsgi.post-install b/main/apache2-mod-wsgi/apache2-mod-wsgi.post-install
new file mode 100644
index 0000000000..327b0156b9
--- /dev/null
+++ b/main/apache2-mod-wsgi/apache2-mod-wsgi.post-install
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+echo "*" >&2
+echo "* To finish installing apache2-mod-wsgi:" >&2
+echo "* 1) See if you need to modify the apache2 config:" >&2
+echo "* /etc/apache2/conf.d/wsgi-module.conf" >&2
+echo "* 2) Restart apache2 when done." >&2
+echo "*" >&2
+
+exit 0