aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-11 14:14:02 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-11 14:14:02 +0200
commit0b83baa0247a75a7c07360848a58a4024f90f9d8 (patch)
tree409f6409ea88efcc987e88b897a0e4c4215478ad /main/apache2
parent35a1326047568cb5c7392d6464a8ef0d4d8f15ca (diff)
downloadaports-0b83baa0247a75a7c07360848a58a4024f90f9d8.tar.bz2
aports-0b83baa0247a75a7c07360848a58a4024f90f9d8.tar.xz
main/apache2: use openssl binary from libressl
Diffstat (limited to 'main/apache2')
-rw-r--r--main/apache2/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index 6e79a6d4b8..042dec0895 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache2
_pkgreal=httpd
pkgver=2.4.23
-pkgrel=5
+pkgrel=6
pkgdesc="A high performance Unix-based HTTP server"
url="http://httpd.apache.org/"
arch="all"
@@ -53,10 +53,10 @@ source="http://archive.apache.org/dist/$_pkgreal/$_pkgreal-$pkgver.tar.bz2
"
options="suid"
-_builddir="$srcdir"/$_pkgreal-$pkgver
+builddir="$srcdir"/$_pkgreal-$pkgver
prepare() {
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
@@ -68,7 +68,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--prefix=/usr \
--enable-layout=Alpine \
@@ -114,7 +114,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
# config
@@ -224,7 +224,7 @@ utils() {
ssl() {
pkgdesc="SSL/TLS module for the Apache HTTP Server"
install="apache2-ssl.post-install"
- depends="apache2 openssl"
+ depends="apache2 libressl"
install -d "$subpkgdir"/usr/lib/apache2 || return 1
mv "$pkgdir"/usr/lib/apache2/mod_ssl.so \