aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache2
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-09-21 12:04:51 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-09-21 12:06:50 +0300
commit23278078823bcf134833a70fa94866bece9e17c8 (patch)
tree2ef85cc55f3d48a9fcc2a0c1b1df421f71277e67 /main/apache2
parent9513e587b007defbb6ef3590945ff49cbd73a270 (diff)
downloadaports-23278078823bcf134833a70fa94866bece9e17c8.tar.bz2
aports-23278078823bcf134833a70fa94866bece9e17c8.tar.xz
main/apache2: subpackage for apachectl
ref #5505
Diffstat (limited to 'main/apache2')
-rw-r--r--main/apache2/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index cb574c23d1..a4f60d4ceb 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache2
_pkgreal=httpd
pkgver=2.4.27
-pkgrel=1
+pkgrel=2
pkgdesc="A high performance Unix-based HTTP server"
url="http://httpd.apache.org/"
arch="all"
@@ -14,7 +14,8 @@ pkgusers="apache"
pkggroups="apache"
makedepends="apr-dev apr-util-dev autoconf automake libxml2-dev lua-dev
nghttp2-dev libressl-dev pcre-dev sed zlib-dev"
-subpackages="$pkgname-dev
+subpackages="$pkgname-ctl
+ $pkgname-dev
$pkgname-doc
$pkgname-error:_error:noarch
$pkgname-http2
@@ -231,17 +232,23 @@ icons() {
}
utils() {
- local _bin
pkgdesc="Apache utility programs for webservers"
- depends=lynx
- install -d "$subpkgdir"/usr/sbin || return 1
+ install -d "$subpkgdir"/usr/sbin
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
- for i in checkgid htcacheclean rotatelogs apachectl envvars*; do
- mv "$pkgdir"/usr/sbin/$i "$subpkgdir"/usr/sbin/ || return 1
+ for i in checkgid htcacheclean rotatelogs envvars*; do
+ mv "$pkgdir"/usr/sbin/$i "$subpkgdir"/usr/sbin/
done
}
+ctl() {
+ pkgdesc="Apache control script"
+ depends=lynx
+
+ install -d "$subpkgdir"/usr/sbin
+ mv "$pkgdir"/usr/sbin/apachectl "$subpkgdir"/usr/sbin/
+}
+
ssl() {
pkgdesc="SSL/TLS module for the Apache HTTP Server"
install="apache2-ssl.post-install"