aboutsummaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2016-11-21 05:23:28 +0700
committerTimo Teräs <timo.teras@iki.fi>2016-11-21 07:52:08 +0000
commit27318a6c19bc713cda1ec41bc044ca97e21d4db4 (patch)
tree14be30fefaa20413c55c6a3cdb563d9ef7baeab9 /main/apk-tools
parentb1681a85922d7807a35d563ac75e3f4994507003 (diff)
downloadaports-27318a6c19bc713cda1ec41bc044ca97e21d4db4.tar.bz2
aports-27318a6c19bc713cda1ec41bc044ca97e21d4db4.tar.xz
main/apk-tools: add s390x support
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-add-s390x-headers.patch25
-rw-r--r--main/apk-tools/APKBUILD10
2 files changed, 32 insertions, 3 deletions
diff --git a/main/apk-tools/0001-add-s390x-headers.patch b/main/apk-tools/0001-add-s390x-headers.patch
new file mode 100644
index 0000000000..b05da4979c
--- /dev/null
+++ b/main/apk-tools/0001-add-s390x-headers.patch
@@ -0,0 +1,25 @@
+From 24636f5277d6279f7740a46ed446d1bc763c7e91 Mon Sep 17 00:00:00 2001
+From: "Tuan M. Hoang" <tmhoang@flatglobe.org>
+Date: Sun, 20 Nov 2016 22:39:44 +0700
+Subject: [PATCH] add s390x headers
+
+---
+ src/apk_defines.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/apk_defines.h b/src/apk_defines.h
+index 9b2e904..7215360 100644
+--- a/src/apk_defines.h
++++ b/src/apk_defines.h
+@@ -95,6 +95,8 @@ extern char **apk_argv;
+ #define APK_DEFAULT_ARCH "armel"
+ #elif defined(__aarch64__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
+ #define APK_DEFAULT_ARCH "aarch64"
++#elif defined(__s390x__)
++#define APK_DEFAULT_ARCH "s390x"
+ #else
+ #error APK_DEFAULT_ARCH not detected for this architecture
+ #endif
+--
+2.10.2
+
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index ae2cac60d9..ca1b183903 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -13,6 +13,7 @@ if [ "$CBUILD" = "$CHOST" ]; then
makedepends="$makedepends lua5.2-dev"
fi
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ 0001-add-s390x-headers.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -82,6 +83,9 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
-md5sums="cc3efedf3047c256f13549ba58df3291 apk-tools-2.6.8.tar.xz"
-sha256sums="83f5cf9f0e75c19004a67150819eae2d4c859236b6c9c04d34d5b6968925f0d3 apk-tools-2.6.8.tar.xz"
-sha512sums="03fb42616335de9edaf3e44fd64a8d1c5dd8b0f25b7f3b176940b751a6547b8be153549f0cee9a5d65491025f6747799b6f5ba22b15d850593d499c07b5cc4c6 apk-tools-2.6.8.tar.xz"
+md5sums="cc3efedf3047c256f13549ba58df3291 apk-tools-2.6.8.tar.xz
+f77a0ce3b4a67cbefed14c3a3ebf253f 0001-add-s390x-headers.patch"
+sha256sums="83f5cf9f0e75c19004a67150819eae2d4c859236b6c9c04d34d5b6968925f0d3 apk-tools-2.6.8.tar.xz
+db8519fd21f7b302e1b339d037b5b02cbcefcf197891b45af5362d17d8d66bd5 0001-add-s390x-headers.patch"
+sha512sums="03fb42616335de9edaf3e44fd64a8d1c5dd8b0f25b7f3b176940b751a6547b8be153549f0cee9a5d65491025f6747799b6f5ba22b15d850593d499c07b5cc4c6 apk-tools-2.6.8.tar.xz
+7ab0a174c86613631d85cf6e51925b4a5a7ce42b6b02db2166bc5629517edf42d6abc1f9404621161e647b1d61f01641bc4ef91060e98e20b7a4bd4a9758fab5 0001-add-s390x-headers.patch"