aboutsummaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 12:53:03 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-06 12:15:45 +0000
commit72048e01f0eef23b1300eb4c7d8eb2afb601f156 (patch)
tree78e3966a20d2e8241649979d02a584086a70b0a3 /main/apk-tools
parent64473857139be03bc378907d64684bc09767ac86 (diff)
downloadaports-72048e01f0eef23b1300eb4c7d8eb2afb601f156.tar.bz2
aports-72048e01f0eef23b1300eb4c7d8eb2afb601f156.tar.xz
main/apk-tools: depend on zlib-static and openssl-libs-static
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/APKBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 3e7d5556d6..affdcf975d 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,18 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.10.4
-pkgrel=2
+pkgrel=3
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
-depends=
makedepends_build="openssl"
-makedepends_host="zlib-dev openssl-dev linux-headers"
+makedepends_host="zlib-dev openssl-dev zlib-static openssl-libs-static linux-headers"
makedepends="$makedepends_build $makedepends_host"
if [ "$CBUILD" = "$CHOST" ]; then
subpackages="$subpackages lua5.2-apk:luaapk"
makedepends="$makedepends lua5.2-dev"
fi
-source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+source="https://dev.alpinelinux.org/archive/apk-tools/apk-tools-$pkgver.tar.xz
0001-add-fix-virtual-package-id-generation.patch
lua-apk_time.patch
"
@@ -21,12 +20,11 @@ url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
license=GPL2
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
sed -i -e 's:-Werror::' Make.rules
- echo "FULL_VERSION=$pkgver-r$pkgrel" > config.mk || return 1
+ echo "FULL_VERSION=$pkgver-r$pkgrel" > config.mk
if [ "$CBUILD" = "$CHOST" ]; then
echo "LUAAPK=YesPlease" >> config.mk
else
@@ -37,8 +35,8 @@ prepare() {
build() {
cd "$builddir"
- make || return 1
- make static || return 1
+ make
+ make static
}
check() {
@@ -52,8 +50,7 @@ package() {
install -d "$pkgdir"/var/lib/apk \
"$pkgdir"/var/cache/misc \
"$pkgdir"/etc/apk/keys \
- "$pkgdir"/etc/apk/protected_paths.d \
- || return 1
+ "$pkgdir"/etc/apk/protected_paths.d
# the shipped README is empty
rm -r "$pkgdir"/usr/share/
}
@@ -70,12 +67,12 @@ static() {
local abuild_userconf=${ABUILD_USERCONF:-"$abuild_home/abuild.conf"}
[ -f "$abuild_userconf" ] && . "$abuild_userconf"
local privkey="$PACKAGER_PRIVKEY"
- local pubkey=${PACKAGER_PUBKEY:-"${privkey}.pub"}
+ local pubkey=${PACKAGER_PUBKEY:-"$privkey.pub"}
local keyname=${pubkey##*/}
${CROSS_COMPILE}strip "$subpkgdir"/sbin/apk.static
openssl dgst -sha1 -sign "$privkey" \
-out "$subpkgdir"/sbin/apk.static.SIGN.RSA.$keyname \
- "$subpkgdir"/sbin/apk.static || return 1
+ "$subpkgdir"/sbin/apk.static
}
luaapk() {