aboutsummaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-14 22:05:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-15 05:59:58 +0000
commit9181dd1c09c96f6620331373a55a6c666d3af826 (patch)
tree05f171ab25929e01c67352b9e0e5d57a98748436 /main/apk-tools
parent37250a4f09d679dc3cdd243dafc16910ac03c3a2 (diff)
downloadaports-9181dd1c09c96f6620331373a55a6c666d3af826.tar.bz2
aports-9181dd1c09c96f6620331373a55a6c666d3af826.tar.xz
main/apk-tools: upgrade to 2.10.0_rc1
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch57
-rw-r--r--main/apk-tools/0002-db-fix-refreshing-index-if-time-is-zero.patch34
-rw-r--r--main/apk-tools/APKBUILD10
3 files changed, 3 insertions, 98 deletions
diff --git a/main/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch b/main/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
deleted file mode 100644
index 107676e93c..0000000000
--- a/main/apk-tools/0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 0dcbd933c8d3d305395a99b7b1690a187ce5ec8c Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Wed, 21 Feb 2018 15:35:53 +0000
-Subject: [PATCH] solver: allow names with only one provider to be autoselected
- regardless of priority
-
----
- src/solver.c | 5 +++--
- test/provides.repo | 9 ++++++++-
- 2 files changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/src/solver.c b/src/solver.c
-index 91e5958..d27a7a3 100644
---- a/src/solver.c
-+++ b/src/solver.c
-@@ -671,11 +671,12 @@ static void select_package(struct apk_solver_state *ss, struct apk_name *name)
- (!p->pkg->ss.iif_triggered ||
- !p->pkg->ss.tag_ok))
- continue;
-- /* Virtual packages without provider_priority cannot be autoselected */
-+ /* Virtual packages without provider_priority cannot be autoselected,
-+ * unless there is only one provider */
- if (p->version == &apk_null_blob &&
- p->pkg->name->auto_select_virtual == 0 &&
- p->pkg->name->ss.requirers == 0 &&
-- p->pkg->provider_priority == 0)
-+ (p->pkg->provider_priority == 0 && name->providers->num > 1))
- continue;
- if (compare_providers(ss, p, &chosen) > 0)
- chosen = *p;
-diff --git a/test/provides.repo b/test/provides.repo
-index 58bd416..358151e 100644
---- a/test/provides.repo
-+++ b/test/provides.repo
-@@ -82,7 +82,7 @@ P:conflicted-provider-b
- V:0.1
- S:1
- I:1
--p:conflicted-provider
-+p:conflicted-provider conflicted-provider-2
-
- C:Q1EyN5AdpAOBJWKMR89ppC66ccccj=
- P:conflicted-dep
-@@ -104,3 +104,10 @@ V:0.1
- S:1
- I:1
- p:self-provide
-+
-+C:Q1EyN5AdpAOBJWKMR89ppC66eeeej=
-+P:conflicted-dep-2
-+V:0.1
-+S:1
-+I:1
-+D:conflicted-provider-2
---
-2.16.1
-
diff --git a/main/apk-tools/0002-db-fix-refreshing-index-if-time-is-zero.patch b/main/apk-tools/0002-db-fix-refreshing-index-if-time-is-zero.patch
deleted file mode 100644
index 263bc71955..0000000000
--- a/main/apk-tools/0002-db-fix-refreshing-index-if-time-is-zero.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 258519b1cd32e285060fa4758c123b55ebfe3ef3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Thu, 5 Apr 2018 09:57:15 +0300
-Subject: [PATCH] db: fix refreshing index if time is zero
-
-During netboot on systems without RTC, time() will be near zero,
-and the index fill not exist. Thus the plain test of st.st_mtime
-against system time failed. Verify that fstatat() succeeds.
----
- src/database.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/src/database.c b/src/database.c
-index 3976d3d..db34ed3 100644
---- a/src/database.c
-+++ b/src/database.c
-@@ -634,9 +634,11 @@ int apk_cache_download(struct apk_database *db, struct apk_repository *repo,
- r = apk_repo_format_real_url(db, repo, pkg, url, sizeof(url));
- if (r < 0) return r;
-
-- if (!(apk_force & APK_FORCE_REFRESH))
-- (void) fstatat(db->cache_fd, cacheitem, &st, 0);
-- if (autoupdate && now - st.st_mtime <= db->cache_max_age) return -EALREADY;
-+ if (autoupdate && !(apk_force & APK_FORCE_REFRESH)) {
-+ if (fstatat(db->cache_fd, cacheitem, &st, 0) == 0 &&
-+ now - st.st_mtime <= db->cache_max_age)
-+ return -EALREADY;
-+ }
-
- apk_message("fetch %s", url);
-
---
-2.16.3
-
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 75c681159d..b8ab2247a4 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.9.1
-pkgrel=3
+pkgver=2.10.0_rc1
+pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
@@ -13,8 +13,6 @@ if [ "$CBUILD" = "$CHOST" ]; then
makedepends="$makedepends lua5.2-dev"
fi
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
- 0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
- 0002-db-fix-refreshing-index-if-time-is-zero.patch
"
url="https://git.alpinelinux.org/cgit/apk-tools/"
@@ -84,6 +82,4 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
-sha512sums="4ffb8d1716bbb94421b1cc4277beb47d369c429f4c3bf597d08949abb7586d30c4504edf2f775bea3b93614a280c12391b956ca8f914fb0ec27799a4a005a145 apk-tools-2.9.1.tar.xz
-5ca2d2f2646032ed8f9f86357e986b054045a80ddb944be6a540566ff7092f38591ec8dfc7ac06b9daededa95e86c0e892ead55f9e8907eb318aed76644f7f97 0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
-6852e1dfce1af502ecd5beadcad920fbde0ec3e34b1dcd010ed80d8f9a44816a51430d6e85b4fe713128ca2d3dc859f53570df39dd5b67fee4a5206b0f85aee8 0002-db-fix-refreshing-index-if-time-is-zero.patch"
+sha512sums="b41421f981a05e51de12297d8d88982caa66af3289681ff48485ae8a7b319587d6383ec0af2400af54735e8a20aab8fbd1481dbee754d750fd6d974e0a075c97 apk-tools-2.10.0_rc1.tar.xz"