aboutsummaryrefslogtreecommitdiffstats
path: root/main/aports-build
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-18 14:17:55 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-18 14:18:57 +0200
commit53f52624a9a680e961e6a01bfabd7f9410483327 (patch)
tree32f90c75df4721dc19fb4f420b32ffa47e4a1fce /main/aports-build
parente807a6800bf61d33fa5ada650ab59d109def9f42 (diff)
downloadaports-53f52624a9a680e961e6a01bfabd7f9410483327.tar.bz2
aports-53f52624a9a680e961e6a01bfabd7f9410483327.tar.xz
main/aports-build: fix repos upload messages
check if we actually upload anything before we report that new packages are uploaded.
Diffstat (limited to 'main/aports-build')
-rw-r--r--main/aports-build/APKBUILD8
-rw-r--r--main/aports-build/aports-build13
2 files changed, 11 insertions, 10 deletions
diff --git a/main/aports-build/APKBUILD b/main/aports-build/APKBUILD
index 28224cb882..0e39ba0a1b 100644
--- a/main/aports-build/APKBUILD
+++ b/main/aports-build/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aports-build
pkgver=0.9
-pkgrel=3
+pkgrel=4
pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux"
url="http://alpinelinux.org"
arch="noarch"
@@ -44,12 +44,12 @@ package() {
}
-md5sums="c9a0030398b4fd76c9517e607673d747 aports-build
+md5sums="caaa301bbcbb6e60fa18fc71c5fd44cf aports-build
cb4807ea64c4368487786217db087bac aports-build.initd
c02d90b2bb0c48e416b707caa8766c50 mqtt-exec.aports-build.confd"
-sha256sums="ac96ed107e88319a7d45425df8c4c0458bc488b1ef19a42431dee246fcabc9f2 aports-build
+sha256sums="97099d6cf6945a185dba23fadc5125a880e627316b1a5aa5d401b1c7e4313ae1 aports-build
3e2d551f72273f37290db342a153abd377397483677a684645d22df7b8a8592f aports-build.initd
7d2001688c3776ffb53c422dee424bcf0346ae20f3df5c6c2f4944022b19cb4d mqtt-exec.aports-build.confd"
-sha512sums="b1455606baff233061e5dba218062966ab636e104e31eb523da6487f0bd7207ab8e2a418225e02996715d938a89e71168e768d7cf1fb1458e70e131c78e31630 aports-build
+sha512sums="3b3e465000359f6a199b953a30be80e3088cdb2631e537dc0bc5192a7b218d7adb60577757444bc7150cd1f9311429b1b58be15582b6fbe1236132663b401fa2 aports-build
821035bda47152c341ec94bf960fa67e3377051826712ceb74f39103e6e422777b6e082231bfb87865653d2b93b7d3154cfc24abf65a52e3e66da69412dd7e41 aports-build.initd
93d26e2055dbb02e863bf76b64a549c100decec3fda612ce96ca1464e6d61befa9f57f202553a25cf323e67e266f532d19c7423ff070943a59b3973946d949fe mqtt-exec.aports-build.confd"
diff --git a/main/aports-build/aports-build b/main/aports-build/aports-build
index c5d33a09d1..90adb4643b 100644
--- a/main/aports-build/aports-build
+++ b/main/aports-build/aports-build
@@ -167,15 +167,16 @@ while true; do
log "uploading packages to $repo"
for i in $upload_pkg; do
- if rsync -ruv --delete-delay --delay-updates \
- $repo/$arch $i/$repo/; then
- $upload_msg "$rel/$repo/$arch"
- else
+ rsync -rui --delete-delay --delay-updates \
+ $repo/$arch $i/$repo/ > /tmp/upload-$repo
+ if [ $? -ne 0]; then
rc=1
+ elif [ -s /tmp/upload-$repo ]; then
+ $upload_msg "$rel/$repo/$arch"
+ # report to irc that we are done with repo
+ send_irc "files from $_current uploaded to $repo"
fi
done
- # report to irc that we are done with repo
- send_irc "files from $_current uploaded to $repo"
done
[ $rc -eq 0 ] && touch /tmp/uploaded && sudo apk update