aboutsummaryrefslogtreecommitdiffstats
path: root/main/aports-build
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-01 12:39:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-01 12:39:08 +0000
commit5a3a2025bd1fd60c535a9b52f55fcb758f7d4fa8 (patch)
treee6cdd856218ed828b1b60aa0b2c975460d05db67 /main/aports-build
parent61b6c314dce6d6a6b5e2ce3e2bdd57d9d8824636 (diff)
downloadaports-5a3a2025bd1fd60c535a9b52f55fcb758f7d4fa8.tar.bz2
aports-5a3a2025bd1fd60c535a9b52f55fcb758f7d4fa8.tar.xz
main/aports-build: send status messages only to mqtt
Diffstat (limited to 'main/aports-build')
-rw-r--r--main/aports-build/APKBUILD8
-rw-r--r--main/aports-build/aports-build21
2 files changed, 15 insertions, 14 deletions
diff --git a/main/aports-build/APKBUILD b/main/aports-build/APKBUILD
index 725bd19cfc..51c730c239 100644
--- a/main/aports-build/APKBUILD
+++ b/main/aports-build/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aports-build
-pkgver=0.5
+pkgver=0.6
pkgrel=0
pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux"
url="http://alpinelinux.org"
@@ -39,12 +39,12 @@ package() {
"$pkgdir"/etc/conf.d/aports-build || return 1
}
-md5sums="dc5386f37016c64e1cc68429948f0cdb aports-build
+md5sums="a602113ea927c9db51bf251b5a9286be aports-build
784238e965ca025c0c6ed13c8af01613 aports-build.initd
cdc49e0ef145de72131972a575f20e7b aports-build.confd"
-sha256sums="16f93f98be45bf35421b31138d4e00f08ac46537ef9bd7e5172c29e1d7e05ff0 aports-build
+sha256sums="e8a8a8446c56a8700aeef25cbba3955451d5b1c05a13746d3b4fff67cb79f2ed aports-build
88215b5969e5ffeda549c6e31de4563569ddee2ac3220c381d40f382d43f8323 aports-build.initd
519744cdb4be83e5da1c22d4aa93c7ef97d66e03565e84b710bc21c94b82047e aports-build.confd"
-sha512sums="fa53869dd34bbb636c7f3ff78ca38506571dd5497694c3b8a6395cda682843e7a7b65d4a83ffb9f83ac46b77a6b8f66729c51af928516840d85e54ccd111a312 aports-build
+sha512sums="ec631ca92a57062282aff98b49c603606f201a495764a32a20696f135079c51be2a9b1c2063c8df07f7b57fd4ffa98ba9cd93829c7f54ab785a79edd61e6c12e aports-build
2ef2fa6de4118209ab93a56216f106ac32078df762f4d67e900976c28bea96d44806f4679ef966472a3eb05fdaf1648aab17c0eaa897e8a06b1272766f29d22b aports-build.initd
fbe8ed4b1fbfc979de62302873e99c67bab751a7fcd921c3b23815f535cedb34c717e82b3c223f88e06498a573cbd147a73db7bf5adbb5e1947ac75fcb8edcb4 aports-build.confd"
diff --git a/main/aports-build/aports-build b/main/aports-build/aports-build
index 4aae10239b..1ddb90febe 100644
--- a/main/aports-build/aports-build
+++ b/main/aports-build/aports-build
@@ -85,6 +85,16 @@ new_release() {
return 0
}
+build() {
+ ( $buildrepo $repos || echo "FAIL" ) | while read line; do
+ case "$line" in
+ FAIL) return 1;;
+ [0-9]*/[0-9]*) $status_msg "$line";;
+ *) echo "$line";;
+ esac
+ done
+}
+
cd $aports || return 1
[ -z "$repos" ] && return 1
@@ -128,16 +138,7 @@ while true; do
# do the compile, send output to log
log "building $_current"
-# # temp workaround - abuild does not resolve the linux kernel dep
-# (
-# cd $HOME/aports/main
-# for i in linux-*; do
-# (
-# export REPODEST=$HOME/packages
-# cd $i && abuild -Rk )||break
-# done
-# )
- if ! $buildrepo $repos >"$logdir"/$hostname.log 2>&1 ; then
+ if ! build >"$logdir"/$hostname.log 2>&1 ; then
local errlog=$hostname.$_current.log
cp "$logdir"/$hostname.log "$logdir"/$errlog
# todo: revert last commit?