aboutsummaryrefslogtreecommitdiffstats
path: root/main/aports-build
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-02 14:14:08 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-02 14:14:39 +0200
commitbd5e710d6d4ce65202ab6065173a243e8314b6f5 (patch)
tree9df731a18b85303998fc8462f213f52a78fac844 /main/aports-build
parentbe405f1312b2c66e23678c6ec3013783737fdb02 (diff)
downloadaports-bd5e710d6d4ce65202ab6065173a243e8314b6f5.tar.bz2
aports-bd5e710d6d4ce65202ab6065173a243e8314b6f5.tar.xz
main/aports-build: keep main build log for all repos
Diffstat (limited to 'main/aports-build')
-rw-r--r--main/aports-build/APKBUILD8
-rw-r--r--main/aports-build/aports-build3
2 files changed, 6 insertions, 5 deletions
diff --git a/main/aports-build/APKBUILD b/main/aports-build/APKBUILD
index d67b4bfa9c..bf550e7e31 100644
--- a/main/aports-build/APKBUILD
+++ b/main/aports-build/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aports-build
pkgver=1.0
-pkgrel=8
+pkgrel=9
pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux"
url="http://alpinelinux.org"
arch="noarch"
@@ -49,15 +49,15 @@ package() {
|| return 1
}
-md5sums="039ec1116bad88ea9d83654693db9ae3 aports-build
+md5sums="3b6d3dafbd970bb4b6a7c781895d40b6 aports-build
cb4807ea64c4368487786217db087bac aports-build.initd
c02d90b2bb0c48e416b707caa8766c50 mqtt-exec.aports-build.confd
ea60ae81dc6557b0312f181c8c8aeecf report-build-errors.lua"
-sha256sums="e0336d4f1cd5d76b6b83d8add773454f725d28e841d3036e243dca144945b017 aports-build
+sha256sums="44aba1c40ccd0afec6c5ebe5f6409b583523f6faceb18d0aed7df7edc1cdddf8 aports-build
3e2d551f72273f37290db342a153abd377397483677a684645d22df7b8a8592f aports-build.initd
7d2001688c3776ffb53c422dee424bcf0346ae20f3df5c6c2f4944022b19cb4d mqtt-exec.aports-build.confd
b3d083ed4609ec92630819b638cd5dafdad17df68b25aa6da4c70de901910448 report-build-errors.lua"
-sha512sums="d84559c92514d49f3364f447c3b64317c3b01995963d895872f4f8dc018340bb6d3e870af2b5f4ae49180d45fbb332bf5b14028eae674b02c15285d88cf24498 aports-build
+sha512sums="70f88f8eeee743e3e954b5ad05855080b1d8367abe50b9e6d4de25fb5f2b6c2f781285861570c16b2c56e0603eeb76a5f3fb77d1e0353c9e6bc34ac4c89bfcf4 aports-build
821035bda47152c341ec94bf960fa67e3377051826712ceb74f39103e6e422777b6e082231bfb87865653d2b93b7d3154cfc24abf65a52e3e66da69412dd7e41 aports-build.initd
93d26e2055dbb02e863bf76b64a549c100decec3fda612ce96ca1464e6d61befa9f57f202553a25cf323e67e266f532d19c7423ff070943a59b3973946d949fe mqtt-exec.aports-build.confd
3453e45cb687d2af6cd1c490fd5b7134f643570a84b354b57ba49295e5a0d01ef65abc0909aeb424cbe48aa280c19cc4f1dce5f4f10e5137a80395c3be00c733 report-build-errors.lua"
diff --git a/main/aports-build/aports-build b/main/aports-build/aports-build
index 94a453c28d..9a652418dc 100644
--- a/main/aports-build/aports-build
+++ b/main/aports-build/aports-build
@@ -149,9 +149,10 @@ while true; do
# do the compile, send output to log
log "building $_current"
+ rm -f "$logdir"/$hostname.log
rc=0
for repo in $repos; do
- if ! build $repo >"$logdir"/$hostname.log 2>&1 ; then
+ if ! build $repo >>"$logdir"/$hostname.log 2>&1 ; then
errlog=$hostname.$_current.log
cp "$logdir"/$hostname.log "$logdir"/$errlog
# todo: revert last commit?