aboutsummaryrefslogtreecommitdiffstats
path: root/main/asterisk/musl-libcap.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-08-06 09:17:51 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-08-06 09:19:38 +0300
commita75e6feb7cbd28e93abe95b9bdb0b5c86a9f6532 (patch)
tree402f27f80a9dae08bdb82f21c54dbf6e316a1f48 /main/asterisk/musl-libcap.patch
parentde8a15f9851eecf642bd4c4cbc59c39b59fe317f (diff)
downloadaports-a75e6feb7cbd28e93abe95b9bdb0b5c86a9f6532.tar.bz2
aports-a75e6feb7cbd28e93abe95b9bdb0b5c86a9f6532.tar.xz
main/asterisk: various fixes and clean ups
- remove unused uclibc patches - fix libcap with musl - enable iconv as it is built into musl - import mp3 addon as patch instead of svn checkout - update ASTERISK-23818 patch from upstream
Diffstat (limited to 'main/asterisk/musl-libcap.patch')
-rw-r--r--main/asterisk/musl-libcap.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/asterisk/musl-libcap.patch b/main/asterisk/musl-libcap.patch
new file mode 100644
index 0000000000..d7ce52e7be
--- /dev/null
+++ b/main/asterisk/musl-libcap.patch
@@ -0,0 +1,41 @@
+diff -ru asterisk-12.4.0.orig/configure.ac asterisk-12.4.0/configure.ac
+--- asterisk-12.4.0.orig/configure.ac 2014-08-06 09:07:19.000000000 -0300
++++ asterisk-12.4.0/configure.ac 2014-08-06 09:10:16.350632198 -0300
+@@ -1259,9 +1259,11 @@
+ AST_EXT_LIB_CHECK([BFD], [bfd], [bfd_check_format], [bfd.h], [-ldl -liberty -lz])
+ fi
+
+-if test "x${OSARCH}" = "xlinux-gnu" ; then
++case "${OSARCH}" in
++linux*)
+ AST_EXT_LIB_CHECK([CAP], [cap], [cap_from_text], [sys/capability.h])
+-fi
++ ;;
++esac
+
+ AST_C_DEFINE_CHECK([DAHDI], [DAHDI_RESET_COUNTERS], [dahdi/user.h], [230])
+ AST_C_DEFINE_CHECK([DAHDI], [DAHDI_DEFAULT_MTU_MRU], [dahdi/user.h], [220])
+diff -ru asterisk-12.4.0.orig/main/Makefile asterisk-12.4.0/main/Makefile
+--- asterisk-12.4.0.orig/main/Makefile 2014-08-06 08:53:33.000000000 -0300
++++ asterisk-12.4.0/main/Makefile 2014-08-06 09:07:59.210630841 -0300
+@@ -1,4 +1,3 @@
+-#
+ # Asterisk -- An open source telephony toolkit.
+ #
+ # Makefile to build main Asterisk binary
+@@ -40,14 +39,12 @@
+ AST_LIBS+=$(URIPARSER_LIB)
+ AST_LIBS+=$(UUID_LIB)
+ AST_LIBS+=$(CRYPT_LIB)
++AST_LIBS+=$(CAP_LIB)
+
+ ifneq ($(findstring $(OSARCH), linux-gnu uclinux linux-uclibc kfreebsd-gnu),)
+ ifneq ($(findstring LOADABLE_MODULES,$(MENUSELECT_CFLAGS)),)
+ AST_LIBS+=-ldl
+ endif
+- ifneq (x$(CAP_LIB),x)
+- AST_LIBS+=$(CAP_LIB)
+- endif
+ AST_LIBS+=-lpthread $(EDITLINE_LIB) -lm -lresolv
+ else
+ AST_LIBS+=$(EDITLINE_LIB) -lm