aboutsummaryrefslogtreecommitdiffstats
path: root/main/atf/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-31 14:15:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-31 18:35:07 +0000
commit104e290b2e3f271694cab5d53b25621a0a418a43 (patch)
treeb7bfaef169b843261b715a327f0edbdbd41831ab /main/atf/APKBUILD
parent8abdb0d149e18bb3169e7df14cbd2fe5cfeee985 (diff)
downloadaports-104e290b2e3f271694cab5d53b25621a0a418a43.tar.bz2
aports-104e290b2e3f271694cab5d53b25621a0a418a43.tar.xz
main/atf: modernize
Diffstat (limited to 'main/atf/APKBUILD')
-rw-r--r--main/atf/APKBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/main/atf/APKBUILD b/main/atf/APKBUILD
index 435fd75b7a..ee6d71c3e9 100644
--- a/main/atf/APKBUILD
+++ b/main/atf/APKBUILD
@@ -1,21 +1,16 @@
-# Maintainer:
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=atf
pkgver=0.21
-pkgrel=1
+pkgrel=2
pkgdesc="libraries to write tests in C, C++ and shell"
url="https://github.com/jmmv/atf"
arch="all"
-license="BSD"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
+license="BSD-2-Clause AND BSD-3-Clause"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="https://github.com/jmmv/atf/releases/download/atf-$pkgver/atf-$pkgver.tar.gz"
-builddir="$srcdir/atf-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +22,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}