aboutsummaryrefslogtreecommitdiffstats
path: root/main/atk
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-31 15:57:10 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 04:35:16 +0000
commitb387d1c888dd824f3d8eebbdc4b93f9e0f862f05 (patch)
tree5271d0820f69fa3f6df1f9306800e2603ad1de3d /main/atk
parent967f38c32cb13f307a9cfc635e363250e219e750 (diff)
downloadaports-b387d1c888dd824f3d8eebbdc4b93f9e0f862f05.tar.bz2
aports-b387d1c888dd824f3d8eebbdc4b93f9e0f862f05.tar.xz
main/atk: add test suite
Diffstat (limited to 'main/atk')
-rw-r--r--main/atk/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/main/atk/APKBUILD b/main/atk/APKBUILD
index 8d56da652f..5e6b439fe4 100644
--- a/main/atk/APKBUILD
+++ b/main/atk/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=atk
pkgver=2.26.1
-pkgrel=1
+pkgrel=2
pkgdesc="A library providing a set of interfaces for accessibility"
url="https://www.gtk.org/"
arch="all"
license="LGPL-2.0-or-later"
depends=""
-makedepends="glib-dev gobject-introspection-dev"
+makedepends="glib-dev gobject-introspection-dev musl-utils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -22,6 +22,14 @@ build() {
make
}
+check() {
+ cd "$builddir"/tests
+ # There is no test suite runner present, but the tests are built..
+ for testapp in testdocument testrelation testrole teststateset testvalue; do
+ ./$testapp
+ done
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install