aboutsummaryrefslogtreecommitdiffstats
path: root/main/attr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-01 10:09:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-01 10:13:59 +0000
commita4bb590c51eaff97ac3f63703f4a48e1e5311bbf (patch)
tree27b9dd555bb157bc34fd6f20598deab515f56479 /main/attr
parent15ff5efa588211345e5341f43460b4594a305bb4 (diff)
downloadaports-a4bb590c51eaff97ac3f63703f4a48e1e5311bbf.tar.bz2
aports-a4bb590c51eaff97ac3f63703f4a48e1e5311bbf.tar.xz
main/attr: fix build with busybox gzip
we want reduce number of dependencies to make it easier to bootstrap
Diffstat (limited to 'main/attr')
-rw-r--r--main/attr/APKBUILD8
-rw-r--r--main/attr/busybox-gzip.patch26
2 files changed, 31 insertions, 3 deletions
diff --git a/main/attr/APKBUILD b/main/attr/APKBUILD
index 0d208a3c3c..a3804b08ce 100644
--- a/main/attr/APKBUILD
+++ b/main/attr/APKBUILD
@@ -1,17 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=attr
pkgver=2.4.47
-pkgrel=6
+pkgrel=7
pkgdesc="Utilities for managing filesystem extended attributes"
url="https://savannah.nongnu.org/projects/attr"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
depends=""
-makedepends="libtool autoconf automake bash gzip"
+makedepends="libtool autoconf automake bash"
subpackages="$pkgname-dev $pkgname-doc libattr"
source="http://download.savannah.nongnu.org/releases/attr/attr-$pkgver.src.tar.gz
fix-decls.patch
fix-throw.patch
+ busybox-gzip.patch
"
prepare() {
@@ -67,4 +68,5 @@ libattr() {
sha512sums="2a333f63655758298650cf8f89c175efdc0112dcc4013e8d023e2a9a69f177e4bcb1f1d10b6666d6f2027dca4dec0833d54749952ab153d28367e1a72e6e2831 attr-2.4.47.src.tar.gz
fa7925f63c611e39b28adbf8fa3838bd91c245e4694957c1a8e212cb8f289eb62e04f50806227f6c1947d432ddf7633a471c13dd08d513d1e2b8a9ac1906cb33 fix-decls.patch
-d758b864bac9bdbc3360df2e7a3bc7d04e06789975cf539b8e2b98b1d874744b55c80f0502e283f7233d6ec41f8a39624fe07b512a7fdc6af8d19dd3af5f9f5a fix-throw.patch"
+d758b864bac9bdbc3360df2e7a3bc7d04e06789975cf539b8e2b98b1d874744b55c80f0502e283f7233d6ec41f8a39624fe07b512a7fdc6af8d19dd3af5f9f5a fix-throw.patch
+c04f3f38eafaa1afbafdf99751cdf1770e81182ebdc20f3cbea81d44638f7100c5c9963c42342c618286f25c435a82fcbcd3dea635725042edd36c6a3a02960c busybox-gzip.patch"
diff --git a/main/attr/busybox-gzip.patch b/main/attr/busybox-gzip.patch
new file mode 100644
index 0000000000..ebf1269707
--- /dev/null
+++ b/main/attr/busybox-gzip.patch
@@ -0,0 +1,26 @@
+diff --git a/doc/Makefile b/doc/Makefile
+index c10ced6..524b5a2 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -28,7 +28,7 @@ default: $(SUBDIRS) CHANGES.gz
+ include $(BUILDRULES)
+
+ CHANGES.gz:
+- $(ZIP) --best -c < CHANGES > $@
++ $(ZIP) -c < CHANGES > $@
+
+ install: default
+ $(SUBDIRS_MAKERULE)
+diff --git a/include/buildmacros b/include/buildmacros
+index 9e81bb8..b33e148 100644
+--- a/include/buildmacros
++++ b/include/buildmacros
+@@ -139,7 +139,7 @@ endif
+ MAN_MAKERULE = \
+ @for f in *.[12345678] ""; do \
+ if test ! -z "$$f"; then \
+- $(ZIP) --best -c < $$f > $$f.gz; \
++ $(ZIP) -c < $$f > $$f.gz; \
+ fi; \
+ done
+