aboutsummaryrefslogtreecommitdiffstats
path: root/main/augeas
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-28 19:22:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 19:22:29 +0000
commit510677c4b1d3b766f8b640afac5ca779b905d1c5 (patch)
treeabb126a804f5372dc1217df7f0e6ff4a5cb716c4 /main/augeas
parent81301855c6684a0bb7b4bfce3088fb59feb761bb (diff)
downloadaports-510677c4b1d3b766f8b640afac5ca779b905d1c5.tar.bz2
aports-510677c4b1d3b766f8b640afac5ca779b905d1c5.tar.xz
main/augeas: fix test
problem with test/test-preserve.sh was that it compared the group column from out put of ls. If the group name was longer than 8 the test would fail because busybox' ls truncate the groupname. We solve this by using stat -c %G instead, which does not truncate the group name.
Diffstat (limited to 'main/augeas')
-rw-r--r--main/augeas/APKBUILD6
-rw-r--r--main/augeas/fix-test.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index 233a4e95a5..80aa5451a8 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -10,6 +10,7 @@ depends=""
makedepends="readline-dev libxml2-dev"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-tests::noarch $pkgname-libs"
source="http://download.augeas.net/augeas-$pkgver.tar.gz
+ fix-test.patch
acf.aug"
builddir="$srcdir/$pkgname-$pkgver"
@@ -68,8 +69,9 @@ static() {
check() {
cd "$builddir"
- make -j1 check
+ make check
}
sha512sums="340aed78ac2df455770735b41f3c10a1cbe40f160e236a735d4580edf5b635afeaf7ddadc10e759e9197c4b233e98b3b6b94a3c2f072aa765c104d64371ce171 augeas-1.9.0.tar.gz
+9768878b2f8710436ef1eba7868c22b5eff1d2d549434bf76aced72ebdb4af4f769ea638dedf42ac9b617aaa53d1a767ed6b18868dd0bb3cf72cb3889f6d933a fix-test.patch
74d728abdf4d3eebdeb3823c1d2588c214fd52734c8855fe3ddbfb6465d31c88d093df356e42effdd3dbdff1a62c52894c7aa840bd6ea8df4995c4f3aa53e919 acf.aug"
diff --git a/main/augeas/fix-test.patch b/main/augeas/fix-test.patch
new file mode 100644
index 0000000000..540aeba513
--- /dev/null
+++ b/main/augeas/fix-test.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/test-preserve.sh b/tests/test-preserve.sh
+index 40b8689..f3e9b87 100755
+--- a/tests/test-preserve.sh
++++ b/tests/test-preserve.sh
+@@ -40,7 +40,7 @@ if [ $? != 0 ] ; then
+ exit 1
+ fi
+
+-act_group=$(ls -l $hosts | sed -e 's/ */ /g' | cut -d ' ' -f 4)
++act_group=$(stat -c "%G" $hosts)
+ act_mode=$(ls -l $hosts | cut -b 1-10)
+ if [ $selinux = yes ] ; then
+ act_con=$(stat --format=%C $hosts | cut -d ':' -f 3)