aboutsummaryrefslogtreecommitdiffstats
path: root/main/augeas
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2015-03-25 14:13:54 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2015-03-25 14:14:49 +0200
commit78c3ff3c64ddd48f408771f58b22c5030d5ca399 (patch)
treecc36777b2f64f775c8d2d3484fa90368ad9bf0af /main/augeas
parentc01fda0e709162f47ecad9d38f34f300df48a223 (diff)
downloadaports-78c3ff3c64ddd48f408771f58b22c5030d5ca399.tar.bz2
aports-78c3ff3c64ddd48f408771f58b22c5030d5ca399.tar.xz
main/augeas: Dns_Zone: allow whitespace at the end of line
Diffstat (limited to 'main/augeas')
-rw-r--r--main/augeas/0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch65
-rw-r--r--main/augeas/APKBUILD6
2 files changed, 70 insertions, 1 deletions
diff --git a/main/augeas/0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch b/main/augeas/0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch
new file mode 100644
index 0000000000..09be128581
--- /dev/null
+++ b/main/augeas/0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch
@@ -0,0 +1,65 @@
+From 796b2d796a7e05788d707f178383dc22f384563b Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Wed, 25 Mar 2015 12:23:05 +0200
+Subject: [PATCH 2/2] Dns_Zone: allow whitespace at the end of the line
+
+---
+ lenses/dns_zone.aug | 4 ++--
+ lenses/tests/test_dns_zone.aug | 29 +++++++++++++++++++++++++++++
+ 2 files changed, 31 insertions(+), 2 deletions(-)
+
+diff --git a/lenses/dns_zone.aug b/lenses/dns_zone.aug
+index 77c3485..4db194c 100644
+--- a/lenses/dns_zone.aug
++++ b/lenses/dns_zone.aug
+@@ -16,8 +16,8 @@ module Dns_Zone =
+
+ autoload xfm
+
+-let eol = del /(([ \t\n]*;[^\n]*)?\n)+/ "\n"
+-let opt_eol = del /(([ \t\n]*;[^\n]*)?\n)*/ ""
++let eol = del /([ \t\n]*(;[^\n]*)?\n)+/ "\n"
++let opt_eol = del /([ \t\n]*(;[^\n]*)?\n)*/ ""
+
+ let ws = del /[ \t]+|(([ \t\n]*;[^\n]*)?\n)+[ \t]*/ " "
+ let opt_ws = del /(([ \t\n]*;[^\n]*)?\n)*[ \t]*/ ""
+diff --git a/lenses/tests/test_dns_zone.aug b/lenses/tests/test_dns_zone.aug
+index 07ff583..2537c4d 100644
+--- a/lenses/tests/test_dns_zone.aug
++++ b/lenses/tests/test_dns_zone.aug
+@@ -353,3 +353,32 @@ bar TXT \"ab cd\\\\ef\\\"gh\"
+ { "$ORIGIN" = "example.com." }
+ { "foo" { "1" { "type" = "TXT" } { "rdata" = "abc\\\\def\\\"ghi" } } }
+ { "bar" { "1" { "type" = "TXT" } { "rdata" = "\"ab cd\\\\ef\\\"gh\"" } } }
++
++
++(* Whitespace at the end of the line *)
++test lns get "
++$ORIGIN example.com. \n@ IN SOA ns root.example.com. (1 2 3 4 5) \t
++foo 1D IN A 10.1.2.3\t
++" =
++ { "$ORIGIN" = "example.com." }
++ { "@"
++ { "1"
++ { "class" = "IN" }
++ { "type" = "SOA" }
++ { "mname" = "ns" }
++ { "rname" = "root.example.com." }
++ { "serial" = "1" }
++ { "refresh" = "2" }
++ { "retry" = "3" }
++ { "expiry" = "4" }
++ { "minimum" = "5" }
++ }
++ }
++ { "foo"
++ { "1"
++ { "ttl" = "1D" }
++ { "class" = "IN" }
++ { "type" = "A" }
++ { "rdata" = "10.1.2.3" }
++ }
++ }
+--
+2.1.0
+
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index e0734f2de8..8c62950226 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -13,6 +13,7 @@ install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tests $pkgname-libs"
source="http://download.augeas.net/augeas-$pkgver.tar.gz
0001-Dns_Zone-new-lens-to-parse-DNS-zone-files.patch
+ 0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch
0001-Dnsmasq-add-structure-to-address-and-server-options.patch
0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
@@ -77,6 +78,7 @@ libs() {
md5sums="c8890b11a04795ecfe5526eeae946b2d augeas-1.3.0.tar.gz
cf358f5ff6c222cebd443922bf7ab51d 0001-Dns_Zone-new-lens-to-parse-DNS-zone-files.patch
+e63c8127cf269ad6bb7756dbbf343b9d 0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch
b140791828aec2037c411164102ef8cd 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
0b7d8ef1d472a1cd3b5742afcbc40c7b 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
51c15f48a3086aedcb9b50c379396e9a 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
@@ -91,6 +93,7 @@ e48785687b03c48022426182fbba785e 0009-Shellvars-case-support-on-same-line-with-
4bfc55219b2a1284b84c739951221f63 0011-Shellvars-allow-command-specific-environment-variabl.patch"
sha256sums="80763031af76515a8ea66013ddc3c466742a15d2e907c7c8e2e3b7410262e2af augeas-1.3.0.tar.gz
f025c4cf27dee9c59a5f4a0eede5e4843c4b28cea0d7c32ed7f07181d71acb47 0001-Dns_Zone-new-lens-to-parse-DNS-zone-files.patch
+8bcd28d8f7a41e81933c3be5e61257c1e4188442156ca25459a4a3acfa25d5f8 0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch
0cb29dfdef3f293c5a4db06704072a6672ce728c82d4b2a7260da341522efc37 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
3824c87fca915f2ace1acbcbaed075d8e77268d239d5159aa8603907558f638f 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
e05119d39bba5dd49bf6fa887f38ba3825e308efd9e8dc491694414f740b9737 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
@@ -105,6 +108,7 @@ ef71befc9759945fc953b28c7e81db63057a58297c8dd9642d52ec12e77f105e 0008-Shellvars
61bffc11faf4442f23c22b3a06c329284cfa75ca9db5d27b60ac528dbedc3ba3 0011-Shellvars-allow-command-specific-environment-variabl.patch"
sha512sums="92cc2cf83faa42e83621fe0f73fe9f7247d802f17da781e51d068056d20b1645de1f0ea0d5070c0d5729a3f6554d64a95e31111bf3e44b959386559619843e79 augeas-1.3.0.tar.gz
f495b8f98b08489b46188b5fbd5c571409c323433cf246eeb8daac054b473e61ff39fdbc438b29a37d0435c24ec5720533d064e28d614dd7c520d2b68bef4c7d 0001-Dns_Zone-new-lens-to-parse-DNS-zone-files.patch
+3459aec9948aa8aa80877ffa35b13799e6be818c267e7a60a293d87c908e71399ff3ad856e98da1d4cfbba65b034996384868db86297cf3977307d77c44bca64 0002-Dns_Zone-allow-whitespace-at-the-end-of-the-line.patch
f2cdf6fcd84de4f86bc54d89292d3c4c19070b1c6d5149af6a8d7c49678e2a7527b6549ad114e5ccec53d4d9582814153732f69a4c0228243aac96c48a0e1d1d 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
2a231a4f5db8c86b2710e83d4c74062a67980812df367276fc4876ccb01799881da98d95f0385972a7c229e83c18a758c67e7d5a9bef03fe8e3bd549136dcfc9 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
af2c9021f4f1286e449b0bcb3e9bee781aa7b9be2835fd48cc3fe4e2ac50d4979af06edc6272fd4fc08eaa93a7e7cc77472ca6f9b093090443657630a6512b5a 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch