aboutsummaryrefslogtreecommitdiffstats
path: root/main/augeas
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2016-03-27 23:25:25 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2016-03-29 23:37:52 +0300
commit8ec11477c977576344be65459dd03b9255299617 (patch)
tree07041e48ee047bd94249dbdb2015bde37e733d63 /main/augeas
parenta3bc85c3cd190580d9a95526a4e89b6cdda0a9e0 (diff)
downloadaports-8ec11477c977576344be65459dd03b9255299617.tar.bz2
aports-8ec11477c977576344be65459dd03b9255299617.tar.xz
main/augeas: add paths to default filters
Diffstat (limited to 'main/augeas')
-rw-r--r--main/augeas/0001-add-paths-to-default-filters.patch72
-rw-r--r--main/augeas/APKBUILD21
-rw-r--r--main/augeas/acf.aug7
3 files changed, 94 insertions, 6 deletions
diff --git a/main/augeas/0001-add-paths-to-default-filters.patch b/main/augeas/0001-add-paths-to-default-filters.patch
new file mode 100644
index 0000000000..70798f7aa2
--- /dev/null
+++ b/main/augeas/0001-add-paths-to-default-filters.patch
@@ -0,0 +1,72 @@
+From 36a43b066f77cf3ca28fb1c0de5ce0a3f18b3867 Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Sun, 27 Mar 2016 23:16:24 +0300
+Subject: [PATCH] add paths to default filters
+
+additions mostly specific to Alpine Linux directory layout
+---
+ lenses/cron.aug | 1 +
+ lenses/pg_hba.aug | 1 +
+ lenses/postgresql.aug | 1 +
+ lenses/shellvars.aug | 2 ++
+ 4 files changed, 5 insertions(+)
+
+diff --git a/lenses/cron.aug b/lenses/cron.aug
+index 4787814..6dcf4b4 100644
+--- a/lenses/cron.aug
++++ b/lenses/cron.aug
+@@ -145,6 +145,7 @@ let lns = ( empty | comment | shellvar | entry )*
+ let filter =
+ incl "/etc/cron.d/*" .
+ incl "/etc/crontab" .
++ incl "/etc/crontabs/*" .
+ excl "/etc/cron.d/at.allow" .
+ excl "/etc/cron.d/at.deny" .
+ excl "/etc/cron.d/cron.allow" .
+diff --git a/lenses/pg_hba.aug b/lenses/pg_hba.aug
+index f9b7a0e..a9d165d 100644
+--- a/lenses/pg_hba.aug
++++ b/lenses/pg_hba.aug
+@@ -82,6 +82,7 @@ module Pg_Hba =
+ The pg_hba.conf conf file *)
+ let filter = (incl "/var/lib/pgsql/data/pg_hba.conf" .
+ incl "/var/lib/pgsql/*/data/pg_hba.conf" .
++ incl "/var/lib/postgresql/*/data/pg_hba.conf" .
+ incl "/etc/postgresql/*/*/pg_hba.conf" )
+
+ (* View: lns
+diff --git a/lenses/postgresql.aug b/lenses/postgresql.aug
+index 5f0470b..4946643 100644
+--- a/lenses/postgresql.aug
++++ b/lenses/postgresql.aug
+@@ -71,6 +71,7 @@ let lns = (Util.empty | Util.comment | entry)*
+ (* Variable: filter *)
+ let filter = (incl "/var/lib/pgsql/data/postgresql.conf" .
+ incl "/var/lib/pgsql/*/data/postgresql.conf" .
++ incl "/var/lib/postgresql/*/data/postgresql.conf" .
+ incl "/etc/postgresql/*/*/postgresql.conf" )
+
+ let xfm = transform lns filter
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index 9bc3c9d..03d8fc6 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -289,6 +289,7 @@ module Shellvars =
+ . excl "/etc/default/rmt"
+ . excl "/etc/default/whoopsie"
+ let filter_misc = incl "/etc/arno-iptables-firewall/debconf.cfg"
++ . incl "/etc/conf.d/*"
+ . incl "/etc/cron-apt/config"
+ . incl "/etc/environment"
+ . incl "/etc/firewalld/firewalld.conf"
+@@ -298,6 +299,7 @@ module Shellvars =
+ . incl "/etc/cvs-cron.conf"
+ . incl "/etc/cvs-pserver.conf"
+ . incl "/etc/devscripts.conf"
++ . incl "/etc/kamailio/kamctlrc"
+ . incl "/etc/lintianrc"
+ . incl "/etc/lsb-release"
+ . incl "/etc/os-release"
+--
+2.7.4
+
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index 8597aaac45..7207445d5b 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.4.0
-pkgrel=4
+pkgrel=5
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -30,7 +30,9 @@ source="http://download.augeas.net/augeas-$pkgver.tar.gz
0016-Shellvars-allow-in-commands.patch
0017-Shellvars-allow-wrapping-command-sequences.patch
0018-Shellvars-test-case-for-wrapping-command-arguments.patch
- 0019-Shellvars-allow-command-specific-environment-variabl.patch"
+ 0019-Shellvars-allow-command-specific-environment-variabl.patch
+ 0001-add-paths-to-default-filters.patch
+ acf.aug"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -59,7 +61,8 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
- rm -rf "$pkgdir"/usr/lib/charset.alias
+ rm -rf "$pkgdir"/usr/lib/charset.alias || return 1
+ install -m 644 "$srcdir"/acf.aug "$pkgdir"/usr/share/augeas/lenses
}
tests() {
@@ -98,7 +101,9 @@ d66b1b77d7f39a9d211765364e7cfa0f 0014-Shellvars-Allow-almost-any-command.patch
461ac5da32645468623b2cb1f886acae 0016-Shellvars-allow-in-commands.patch
c3b968af2e2aa423581a564c8107605c 0017-Shellvars-allow-wrapping-command-sequences.patch
5e31b0f813afc1d5b43f52d34baa9832 0018-Shellvars-test-case-for-wrapping-command-arguments.patch
-59e19136f59c70d6c36025124deb389b 0019-Shellvars-allow-command-specific-environment-variabl.patch"
+59e19136f59c70d6c36025124deb389b 0019-Shellvars-allow-command-specific-environment-variabl.patch
+92a6ba9caecffb39c24c7e66bee1febe 0001-add-paths-to-default-filters.patch
+b1b8d849f0125e1124af92b9925f735e acf.aug"
sha256sums="659fae7ac229029e60a869a3b88c616cfd51cf2fba286cdfe3af3a052cb35b30 augeas-1.4.0.tar.gz
590857f339fc3e758624c6854c8686ba19faa7d28bde58d19ffa4513d63d76ed 0001-Shellvars-accept-and-builtins.patch
4ac77be95a2d98185dd7966acb2b8b8e9af24589d50ba8650862835a9388db27 0002-Shellvars-Add-test-for.patch
@@ -118,7 +123,9 @@ bb2a9460a367040186a858bad95aff355fdb9162488bc453125c28ced1680204 0014-Shellvars
5a96fe8d5b513014ef77ecb5c64bb6cf27eba560347d498bcda2bc3cc2e4bc56 0016-Shellvars-allow-in-commands.patch
4191d31076f2751996cdffa5dcc8d3337c7cc197b4e2711c368d9d5f061c27e6 0017-Shellvars-allow-wrapping-command-sequences.patch
9bd9ab6b1902202748e0f3dc004297e64a14a68dee025b4a3951330bfe13ac6b 0018-Shellvars-test-case-for-wrapping-command-arguments.patch
-bf25ccc9a0bf4cd45f91bfcfa9c6b8dd89f0903c1117d74c8eaf61685173a088 0019-Shellvars-allow-command-specific-environment-variabl.patch"
+bf25ccc9a0bf4cd45f91bfcfa9c6b8dd89f0903c1117d74c8eaf61685173a088 0019-Shellvars-allow-command-specific-environment-variabl.patch
+6cf4ae639cb16aa387781af50249bc707e300eb9d3d3dc6d8212122b3a0c70a4 0001-add-paths-to-default-filters.patch
+e3b4e75119c7939d92c91f3f6c6a553a90923572f9c2e387b2b745470ad6dba4 acf.aug"
sha512sums="182457698e51be89feadb16879bae2f2413a5761127efb63a9b7ef30806f4059bca614e8c9627b0c7a010b9ec9c03c85161e655bdb2902f7cf43e89b66e312db augeas-1.4.0.tar.gz
8844c34c2cbf68d605214d0738e2106d5712ddb2e745910bfb99856fb34a2475e9522d68df6e596e2d81423136b1a6a23db9f5f7a0c4dcc43b618017fa493742 0001-Shellvars-accept-and-builtins.patch
d9178f6f90556b14a4c1295fa9ec0649e0d1ef72bc4431e194ba03b42ef20363d8ea057a209f6a2a278a8b072b56241caa7e5fc574d2c3a01bc4f642f05b8eb4 0002-Shellvars-Add-test-for.patch
@@ -138,4 +145,6 @@ c268d6a45bb3978737431ca97b4b1670db8ca765607fe4c632919e2481258702779205532ee5eba4
211339389eea3dce5aaed66db416fade2231c8353ccf4dbb1f9e766a8ac54b5857ca0016783da094daa32e32cd25ffd89b12b6cb3920a1dcaf758913978c088d 0016-Shellvars-allow-in-commands.patch
48b3172aec95b52b1473fda28a99e43a085844497027adba8b8cd8830da4a7d5bf0a6f6eb3dbbab24d8023a3a24ab0d19f355f5242488821ed8bceb34a0b5bf8 0017-Shellvars-allow-wrapping-command-sequences.patch
18d986609523ad968b0e006081ad7073a799f40902c880c4a3e4f2478b2792b5568d68e9fa48fed3314c136dac985ae8ea0a4c8d7152c24cbda1b9fb1e097683 0018-Shellvars-test-case-for-wrapping-command-arguments.patch
-8371f154457b3dbb8a95f73cd39cd9bc6bfde03418174561eb09fd04f76bd6ce7215890c68d45d4b9ac5fef4433c2ef79c01910dc3a3818cfb46a3aa1d8b0082 0019-Shellvars-allow-command-specific-environment-variabl.patch"
+8371f154457b3dbb8a95f73cd39cd9bc6bfde03418174561eb09fd04f76bd6ce7215890c68d45d4b9ac5fef4433c2ef79c01910dc3a3818cfb46a3aa1d8b0082 0019-Shellvars-allow-command-specific-environment-variabl.patch
+2c33b2f6661e950220fa8a15c4c45f0c83dfd453919a17cf27fec02577679fab7349c88e242fb65c11fcb159f19d72242aaaf87ea457b9fe674299d05b7dc73d 0001-add-paths-to-default-filters.patch
+74d728abdf4d3eebdeb3823c1d2588c214fd52734c8855fe3ddbfb6465d31c88d093df356e42effdd3dbdff1a62c52894c7aa840bd6ea8df4995c4f3aa53e919 acf.aug"
diff --git a/main/augeas/acf.aug b/main/augeas/acf.aug
new file mode 100644
index 0000000000..377c0a82a8
--- /dev/null
+++ b/main/augeas/acf.aug
@@ -0,0 +1,7 @@
+(* Copyright (C) 2016 Kaarle Ritvanen *)
+
+module Acf =
+
+autoload xfm
+
+let xfm = transform IniFile.lns_loose (incl "/etc/acf/acf.conf")