aboutsummaryrefslogtreecommitdiffstats
path: root/main/augeas
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-12-26 13:45:15 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-12-26 13:45:53 +0200
commitb4c9e501a19a6c1bb02a0c48e0b8bb0830400146 (patch)
tree6fe4d1476d2b4598b773db0c4967c5cc22924eb2 /main/augeas
parentade8a86e66ba5cf2f630a80857eb3b2ad9aca47a (diff)
downloadaports-b4c9e501a19a6c1bb02a0c48e0b8bb0830400146.tar.bz2
aports-b4c9e501a19a6c1bb02a0c48e0b8bb0830400146.tar.xz
main/augeas: Shellvars: allow command-specific environment
Diffstat (limited to 'main/augeas')
-rw-r--r--main/augeas/0011-Shellvars-allow-command-specific-environment-variabl.patch55
-rw-r--r--main/augeas/APKBUILD14
2 files changed, 64 insertions, 5 deletions
diff --git a/main/augeas/0011-Shellvars-allow-command-specific-environment-variabl.patch b/main/augeas/0011-Shellvars-allow-command-specific-environment-variabl.patch
new file mode 100644
index 0000000000..938c847de0
--- /dev/null
+++ b/main/augeas/0011-Shellvars-allow-command-specific-environment-variabl.patch
@@ -0,0 +1,55 @@
+From e6ca8eadfebbddf87b2ea356db7cbd285ae0f07f Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Fri, 26 Dec 2014 13:27:13 +0200
+Subject: [PATCH 11/11] Shellvars: allow command-specific environment variables
+
+---
+ lenses/shellvars.aug | 4 +++-
+ lenses/tests/test_shellvars.aug | 9 ++++++++-
+ 2 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index 07c7a52..9ee0d05 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -97,7 +97,9 @@ module Shellvars =
+ let command =
+ let reserved_key = /exit|shift|return|ulimit|unset|export|source|\.|if|for|select|while|until|then|else|fi|done|case/
+ in let word = /[A-Za-z0-9_.-\/]+/
+- in Util.indent . label "@command" . store (word - reserved_key)
++ in Util.indent . label "@command"
++ . [ key key_re . eq . store anyquot . Sep.space . del /(\\\\\n[ \t]*)?/ "" ]*
++ . store (word - reserved_key - /zzz/)
+ . [ Sep.space . label "@arg" . sto_to_semicol]?
+
+ (************************************************************************
+diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
+index 68a77ad..dd4132e 100644
+--- a/lenses/tests/test_shellvars.aug
++++ b/lenses/tests/test_shellvars.aug
+@@ -552,7 +552,9 @@ esac\n" =
+ test Shellvars.lns get "echo foobar 'and this is baz'
+ /usr/local/bin/myscript.sh with args
+ echo foo \
+-bar\n" =
++bar
++abc=def \
++ ghi=\"jkl mno\" command arg1 arg2\n" =
+ { "@command" = "echo"
+ { "@arg" = "foobar 'and this is baz'" }
+ }
+@@ -563,6 +565,11 @@ bar\n" =
+ { "@arg" = "foo \
+ bar" }
+ }
++ { "@command" = "command"
++ { "abc" = "def" }
++ { "ghi" = "\"jkl mno\"" }
++ { "@arg" = "arg1 arg2" }
++ }
+
+ (* Local Variables: *)
+ (* mode: caml *)
+--
+1.9.3
+
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index fb27e7c5bd..a71a25965b 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -22,7 +22,8 @@ source="http://download.augeas.net/augeas-$pkgver.tar.gz
0007-Shellvars-Allow-almost-any-command.patch
0008-Shellvars-test-case-for-wrapping-command-arguments.patch
0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
- 0010-Shellvars-allow-the-builtin.patch"
+ 0010-Shellvars-allow-the-builtin.patch
+ 0011-Shellvars-allow-command-specific-environment-variabl.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -84,7 +85,8 @@ b140791828aec2037c411164102ef8cd 0001-Dnsmasq-add-structure-to-address-and-serv
559ce327e30c663ac13a9d654d95ab36 0007-Shellvars-Allow-almost-any-command.patch
f65d801a398dd8124b59f9db8b65ffdb 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
e48785687b03c48022426182fbba785e 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
-07fcbed83f7f507beeac919aa96eb7c4 0010-Shellvars-allow-the-builtin.patch"
+07fcbed83f7f507beeac919aa96eb7c4 0010-Shellvars-allow-the-builtin.patch
+4bfc55219b2a1284b84c739951221f63 0011-Shellvars-allow-command-specific-environment-variabl.patch"
sha256sums="80763031af76515a8ea66013ddc3c466742a15d2e907c7c8e2e3b7410262e2af augeas-1.3.0.tar.gz
0cb29dfdef3f293c5a4db06704072a6672ce728c82d4b2a7260da341522efc37 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
3824c87fca915f2ace1acbcbaed075d8e77268d239d5159aa8603907558f638f 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
@@ -96,7 +98,8 @@ f266d39442cdbc4a173cbe79acf37831e822da49989ab7336b5cf23d1cfebf0c 0004-Shellvars
182e6e511e21de8379cee76f14bc16ce999a5dd1a8cecbef6ea67ee7d7a471f1 0007-Shellvars-Allow-almost-any-command.patch
ef71befc9759945fc953b28c7e81db63057a58297c8dd9642d52ec12e77f105e 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
745e8d28d038f70b10fbf35d301a6d63e780a2a01ae4c5ff3bf207ce629b3d15 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
-13017bf58ec6d7d72d2dd5954d2636f47147207543ccd9537bb08e16ae032406 0010-Shellvars-allow-the-builtin.patch"
+13017bf58ec6d7d72d2dd5954d2636f47147207543ccd9537bb08e16ae032406 0010-Shellvars-allow-the-builtin.patch
+61bffc11faf4442f23c22b3a06c329284cfa75ca9db5d27b60ac528dbedc3ba3 0011-Shellvars-allow-command-specific-environment-variabl.patch"
sha512sums="92cc2cf83faa42e83621fe0f73fe9f7247d802f17da781e51d068056d20b1645de1f0ea0d5070c0d5729a3f6554d64a95e31111bf3e44b959386559619843e79 augeas-1.3.0.tar.gz
f2cdf6fcd84de4f86bc54d89292d3c4c19070b1c6d5149af6a8d7c49678e2a7527b6549ad114e5ccec53d4d9582814153732f69a4c0228243aac96c48a0e1d1d 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
2a231a4f5db8c86b2710e83d4c74062a67980812df367276fc4876ccb01799881da98d95f0385972a7c229e83c18a758c67e7d5a9bef03fe8e3bd549136dcfc9 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
@@ -108,4 +111,5 @@ b19af8a4bb0ab542b449f50ace8ce9ebb83619bb5587b38f012e98bdf5de6ce9673f12f3af26ac14
c7a7ddc3635371a74ac6b943e5b1adeab8960dc0a2d38625d2c1801ab88a60670eb8ff30b1f0938a461519b1b3199273b91e734c3b368c1d500653d5b6b82a0a 0007-Shellvars-Allow-almost-any-command.patch
798201a25b3f42e4cfcc071e7066a4a20492f58574cd7baeea14a60569663d2b2775d6afb361900057f5add61be8e6e2a7e5b2ca395711fd13c30fce2590d5cf 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
0c337e30c77bc41caa0d672cc8db47770a03f4e3ca661b7eacab55bfc66630eef66f23f70f74abc0357890ddf612117405f7512f0b2e993ec4c8e7bb6be2d7c0 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
-9204f19e3234fc3be5bc59a374f9ac943494c1ee37a3c9c88186e2b6c1780e8376517108fe4a2567c6315bdb475ba5f492f9cb61ff569f79054ed17902368149 0010-Shellvars-allow-the-builtin.patch"
+9204f19e3234fc3be5bc59a374f9ac943494c1ee37a3c9c88186e2b6c1780e8376517108fe4a2567c6315bdb475ba5f492f9cb61ff569f79054ed17902368149 0010-Shellvars-allow-the-builtin.patch
+37c1cf7c3e247e8acb73c956a2605ffb6ceadf2f3d3170a9d0c64059a9532830da2f11d105994fcee001138cc91e2432a2fb6f5ee012d98efc99b4b439bde459 0011-Shellvars-allow-command-specific-environment-variabl.patch"