aboutsummaryrefslogtreecommitdiffstats
path: root/main/automake
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-11 13:11:35 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-17 14:00:48 +0000
commitc96e25eb32576f897c09b6b68744782df6cbbdd2 (patch)
tree947e1f7c415984afb2f9ca9172521956d3739530 /main/automake
parent8b8716357348d4e41ab939b29c3b535866874b9f (diff)
downloadaports-c96e25eb32576f897c09b6b68744782df6cbbdd2.tar.bz2
aports-c96e25eb32576f897c09b6b68744782df6cbbdd2.tar.xz
main/automake: add check
Diffstat (limited to 'main/automake')
-rw-r--r--main/automake/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/automake/APKBUILD b/main/automake/APKBUILD
index 4763e1dc5f..446c9b63d0 100644
--- a/main/automake/APKBUILD
+++ b/main/automake/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=automake
pkgver=1.15.1
-pkgrel=0
+pkgrel=1
pkgdesc="A GNU tool for automatically creating Makefiles"
url="https://www.gnu.org/software/automake"
arch="noarch"
license="GPL-2.0-or-later MIT Public-Domain"
depends="perl"
makedepends="autoconf"
+checkdepends="bash gzip"
subpackages="$pkgname-doc"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -21,6 +22,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR=$pkgdir install