aboutsummaryrefslogtreecommitdiffstats
path: root/main/bash
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-11-13 20:14:14 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-16 20:37:14 +0000
commitdb415e44798fbd6a6d36caaadf52524c2c63c1f7 (patch)
tree9173b5ad244f0f1112e10fd797c61332333198a2 /main/bash
parent260888d269acd9852a64d2b8b00dc38f666b50a8 (diff)
downloadaports-db415e44798fbd6a6d36caaadf52524c2c63c1f7.tar.bz2
aports-db415e44798fbd6a6d36caaadf52524c2c63c1f7.tar.xz
main/bash: fix wrong version in bash.pc
Diffstat (limited to 'main/bash')
-rw-r--r--main/bash/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/bash/APKBUILD b/main/bash/APKBUILD
index 6cba929678..fafd574d82 100644
--- a/main/bash/APKBUILD
+++ b/main/bash/APKBUILD
@@ -6,7 +6,7 @@ pkgver=5.0.11
_patchlevel=${pkgver##*.}
_myver=${pkgver%.*}
_patchbase=${_myver/./}
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Bourne Again shell"
url="https://www.gnu.org/software/bash/bash.html"
arch="all"
@@ -55,6 +55,9 @@ prepare() {
done
default_prepare
+
+ # preventively set Version to please 'apk version --check'
+ sed -i "s/@PACKAGE_VERSION@/$pkgver/" "$builddir"/support/bash.pc.in
}
build() {