aboutsummaryrefslogtreecommitdiffstats
path: root/main/bc
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-05 09:34:07 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-18 16:50:20 +0000
commit8396e50c7aba7dc2493d8c0b286a965f2583c3b3 (patch)
tree58095af9bea8991af91d59e1daf63a4f3c879f1b /main/bc
parent5c6b0637d270d25968a7a4f910157b7a7c10a0de (diff)
downloadaports-8396e50c7aba7dc2493d8c0b286a965f2583c3b3.tar.bz2
aports-8396e50c7aba7dc2493d8c0b286a965f2583c3b3.tar.xz
main/bc: upgrade to 1.07.1
Diffstat (limited to 'main/bc')
-rw-r--r--main/bc/APKBUILD19
-rw-r--r--main/bc/bc-1.06.95-memory_leak-1.patch41
-rw-r--r--main/bc/bc-1.06.95-void_uninitialized.patch13
3 files changed, 7 insertions, 66 deletions
diff --git a/main/bc/APKBUILD b/main/bc/APKBUILD
index a6cf9e911f..3fb338a929 100644
--- a/main/bc/APKBUILD
+++ b/main/bc/APKBUILD
@@ -1,20 +1,16 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bc
-pkgver=1.06.95
-pkgrel=4
+pkgver=1.07.1
+pkgrel=0
pkgdesc="An arbitrary precision numeric processing language (calculator)"
-url="http://www.gnu.org/software/bc/bc.html"
+url="https://www.gnu.org/software/bc/bc.html"
arch="all"
license="GPL2+"
-depends=""
-makedepends="flex bison readline-dev texinfo"
+makedepends="ed flex bison readline-dev texinfo"
subpackages="$pkgname-doc"
-source="ftp://alpha.gnu.org/gnu/bc/bc-$pkgver.tar.bz2
- bc-1.06.95-memory_leak-1.patch
- "
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -39,5 +35,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="16ec13f87ef76ad4de77d378ef8d65a582adca1bf661c9d7675e78d940680c77e81a00a01817fde7c1ad1524562d6f933caa5c42a0686f3f85aadbb39393afb1 bc-1.06.95.tar.bz2
-ee655b87f7fbbd7ce9a85218d38f5a971433691e7d34aff8c122b4e5ff94490c7441001dd73da8bab623a29548cd295ef9c3ae760ebf39f4825cc044d35d4eb6 bc-1.06.95-memory_leak-1.patch"
+sha512sums="02126d0db6b6ed06d56cfc292d6f5475ff1e574779d7e69c7809bbb1e13f946f57ea07da2a7666baa092507a951a822044b0970075f75eefe65a5c1999b75d34 bc-1.07.1.tar.gz"
diff --git a/main/bc/bc-1.06.95-memory_leak-1.patch b/main/bc/bc-1.06.95-memory_leak-1.patch
deleted file mode 100644
index 65703f9481..0000000000
--- a/main/bc/bc-1.06.95-memory_leak-1.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Submitted By: Bruce Dubbs (bdubbs at linuxfromscratch dot org)
-Date: 2014-04-18
-Initial Package Version: 1.06.95
-Origin: Gentoo
-Description: Fixes memory leaks and an uninitialized variable
-
-diff -Naur bc-1.06.95.orig/bc/bc.y bc-1.06.95/bc/bc.y
---- bc-1.06.95.orig/bc/bc.y 2006-09-04 21:39:31.000000000 -0500
-+++ bc-1.06.95/bc/bc.y 2014-04-09 13:27:04.602661243 -0500
-@@ -569,6 +569,7 @@
- generate (">");
- break;
- }
-+ free($2);
- }
- | expression '+' expression
- {
-diff -Naur bc-1.06.95.orig/bc/storage.c bc-1.06.95/bc/storage.c
---- bc-1.06.95.orig/bc/storage.c 2006-09-04 21:39:31.000000000 -0500
-+++ bc-1.06.95/bc/storage.c 2014-04-09 13:28:11.770763410 -0500
-@@ -99,6 +99,7 @@
- {
- f = &functions[indx];
- f->f_defined = FALSE;
-+ f->f_void = FALSE;
- f->f_body = (char *) bc_malloc (BC_START_SIZE);
- f->f_body_size = BC_START_SIZE;
- f->f_code_size = 0;
-diff -Naur bc-1.06.95.orig/bc/util.c bc-1.06.95/bc/util.c
---- bc-1.06.95.orig/bc/util.c 2006-09-04 21:39:31.000000000 -0500
-+++ bc-1.06.95/bc/util.c 2014-04-09 13:27:39.841190064 -0500
-@@ -602,8 +602,7 @@
- case FUNCTDEF:
- if (id->f_name != 0)
- {
-- if (namekind != FUNCT)
-- free(name);
-+ free(name);
- /* Check to see if we are redefining a math lib function. */
- if (use_math && namekind == FUNCTDEF && id->f_name <= 6)
- id->f_name = next_func++;
diff --git a/main/bc/bc-1.06.95-void_uninitialized.patch b/main/bc/bc-1.06.95-void_uninitialized.patch
deleted file mode 100644
index c591f782a8..0000000000
--- a/main/bc/bc-1.06.95-void_uninitialized.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://www.pixelbeat.org/programming/oss_bug_flow.html
-https://bugs.gentoo.org/349339
-
---- ./bc/storage.c
-+++ ./bc/storage.c
-@@ -99,6 +99,7 @@
- {
- f = &functions[indx];
- f->f_defined = FALSE;
-+ f->f_void = FALSE;
- f->f_body = (char *) bc_malloc (BC_START_SIZE);
- f->f_body_size = BC_START_SIZE;
- f->f_code_size = 0;