aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-03 07:50:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-03 07:50:58 +0000
commitb689da87298cbd9e2be38c35a8548fe9f97e52d8 (patch)
tree125a0c009b3ad410ff7883e7d4cbf2fc2a08f501 /main/bluez/APKBUILD
parentb4097755f3c8a80331fb5298e1dbdd44f89b5e74 (diff)
downloadaports-b689da87298cbd9e2be38c35a8548fe9f97e52d8.tar.bz2
aports-b689da87298cbd9e2be38c35a8548fe9f97e52d8.tar.xz
main/bluez: update init.d scripts, split hid2hci
the udev rules to start up bluetoothd rules have been removed from upstream. http://git.kernel.org/?p=bluetooth/bluez.git;a=commit;h=2ea98a6a043710ad4958355b62c682b4767f292e
Diffstat (limited to 'main/bluez/APKBUILD')
-rw-r--r--main/bluez/APKBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 3cfe01deb5..6707ba3243 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=4.101
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -11,10 +11,11 @@ replaces="udev"
makedepends="dbus-dev gst-plugins-base-dev alsa-lib-dev libusb-compat-dev
libnl-dev consolekit-dev udev-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-alsa
- $pkgname-cups $pkgname-gstreamer"
+ $pkgname-cups $pkgname-gstreamer $pkgname-hid2hci"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
bluetooth.initd
- bluetooth.confd
+ rfcomm.initd
+ rfcomm.confd
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -23,7 +24,6 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --libexecdir=/lib \
--mandir=/usr/share/man \
--enable-gstreamer \
--enable-alsa \
@@ -46,7 +46,8 @@ package() {
rm "$pkgdir"/usr/lib/*/*.la \
"$pkgdir"/usr/lib/*.la || return 1
install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
- install -Dm644 "$srcdir"/bluetooth.confd "$pkgdir"/etc/conf.d/bluetooth
+ install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
+ install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
}
@@ -75,6 +76,15 @@ gstreamer() {
mv "$pkgdir"/usr/lib/gstreamer* \
"$subpkgdir"/usr/lib/
}
+
+hid2hci() {
+ pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
+ replaces="bluez"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/lib "$subpkgdir"/
+}
+
md5sums="902b390af95c6c5d6d1a17d94c8344ab bluez-4.101.tar.bz2
-c511078403d7d27673581a8bb468b90b bluetooth.initd
-a159d897a057f4675548327329c4cc22 bluetooth.confd"
+701636b72c4fb72b1d81a050471b130c bluetooth.initd
+7672edb8e33c4495ee9febb9864feb10 rfcomm.initd
+7f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"