aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-17 08:58:18 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-17 08:58:18 +0000
commit20497dd86dea2881735bf6eceb62e31ff26f2b0c (patch)
tree64a8198ba7215741217f5134e7faafff14ecff6c /main/bluez
parent68f938c961a1dea4e79dca7f24f630edbaac99f9 (diff)
downloadaports-20497dd86dea2881735bf6eceb62e31ff26f2b0c.tar.bz2
aports-20497dd86dea2881735bf6eceb62e31ff26f2b0c.tar.xz
main/bluez: fix musl build
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD15
-rw-r--r--main/bluez/fix-includes.patch118
2 files changed, 73 insertions, 60 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 9f59d13392..2992ffc1e2 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.11
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -13,12 +13,22 @@ makedepends="dbus-dev libusb-compat-dev udev-dev
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
$pkgname-hid2hci"
source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
+ fix-includes.patch
bluetooth.initd
rfcomm.initd
rfcomm.confd
"
_builddir="$srcdir"/bluez-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -62,14 +72,17 @@ hid2hci() {
}
md5sums="8a2544d8c88e1f4bd3abe9525282b13c bluez-5.11.tar.xz
+5921c749acd1392bb678a0fe72266184 fix-includes.patch
7a5611fa2cf42da2e844f96b2efa9f3b bluetooth.initd
7672edb8e33c4495ee9febb9864feb10 rfcomm.initd
7f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
sha256sums="1ee116dd504fcdc13dc4f1e171ae1e2a3c46395014cbab455fa12f092cceb06e bluez-5.11.tar.xz
+f2b290cec222713e6114f654d2aed77c9bb015f77d8f007d7e81ee0043852a17 fix-includes.patch
d4aef203e184bef4284b3719268c91e07a1e3f84cbdea2ac8ab40a2617ac9186 bluetooth.initd
4430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd
672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd"
sha512sums="0538de58d7e9c9a1c9c3f88214551157e421838839278ccf0648025b17e2e018beecc9a15f2962463081a8ad2a1a81fc1bd642947a0b27bcde1615997c55d670 bluez-5.11.tar.xz
+f371fd4264471ec5032d04265e035b5cd8e4af19291540210dcfb1d0cc1e4217b24e1695ea3f0bbb037ec670cba151b3c046a92df06e0238b9fc8f875c9ae0c8 fix-includes.patch
2c13cde6561c5aa8b2f27306851458966c67853f6ac2358d09019fda14d3d8e3ff6d9f1c90512c67063d1e1954ec05bf117c5fafc7716446cc5786e9cc12c49f bluetooth.initd
8f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd
a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd"
diff --git a/main/bluez/fix-includes.patch b/main/bluez/fix-includes.patch
index a8962b0b7a..cfb73ffd6b 100644
--- a/main/bluez/fix-includes.patch
+++ b/main/bluez/fix-includes.patch
@@ -1,55 +1,6 @@
---- bluez-4.101.orig/audio/ipc.c
-+++ bluez-4.101/audio/ipc.c
-@@ -22,6 +22,7 @@
- */
-
- #include "ipc.h"
-+#include <string.h>
-
- #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-
---- bluez-4.101.orig/compat/bnep.c
-+++ bluez-4.101/compat/bnep.c
-@@ -32,6 +32,7 @@
- #include <stdlib.h>
- #include <sys/socket.h>
- #include <sys/ioctl.h>
-+#include <sys/time.h>
-
- #include <bluetooth/bluetooth.h>
- #include <bluetooth/bnep.h>
---- bluez-4.101.orig/compat/dund.c
-+++ bluez-4.101/compat/dund.c
-@@ -67,7 +67,7 @@
- static int persist;
- static int use_sdp = 1;
- static int auth;
--static int encrypt;
-+static int do_encrypt;
- static int secure;
- static int master;
- static int type = LANACCESS;
-@@ -146,7 +146,7 @@
- lm |= RFCOMM_LM_MASTER;
- if (auth)
- lm |= RFCOMM_LM_AUTH;
-- if (encrypt)
-+ if (do_encrypt)
- lm |= RFCOMM_LM_ENCRYPT;
- if (secure)
- lm |= RFCOMM_LM_SECURE;
-@@ -492,7 +492,7 @@
- break;
-
- case 'E':
-- encrypt = 1;
-+ do_encrypt = 1;
- break;
-
- case 'S':
---- bluez-4.101.orig/network/common.c
-+++ bluez-4.101/network/common.c
-@@ -29,6 +29,7 @@
+--- bluez-5.11.orig/profiles/network/common.c
++++ bluez-5.11/profiles/network/common.c
+@@ -29,10 +29,12 @@
#include <errno.h>
#include <unistd.h>
#include <stdlib.h>
@@ -57,24 +8,73 @@
#include <sys/param.h>
#include <sys/ioctl.h>
#include <sys/socket.h>
---- bluez-4.101.orig/network/connection.c
-+++ bluez-4.101/network/connection.c
-@@ -28,6 +28,7 @@
- #include <stdio.h>
+ #include <sys/wait.h>
++#include <sys/time.h>
+ #include <net/if.h>
+ #include <linux/sockios.h>
+
+--- bluez-5.11.orig/profiles/network/connection.c
++++ bluez-5.11/profiles/network/connection.c
+@@ -29,6 +29,7 @@
+ #include <stdbool.h>
#include <errno.h>
#include <unistd.h>
+#include <sys/time.h>
#include <netinet/in.h>
#include <bluetooth/bluetooth.h>
---- bluez-4.101.orig/src/textfile.h
-+++ bluez-4.101/src/textfile.h
+--- bluez-5.11.orig/src/textfile.h
++++ bluez-5.11/src/textfile.h
@@ -24,6 +24,8 @@
#ifndef __TEXTFILE_H
#define __TEXTFILE_H
+#include <sys/types.h>
+
- int create_dirs(const char *filename, const mode_t mode);
int create_file(const char *filename, const mode_t mode);
int create_name(char *buf, size_t size, const char *path,
+ const char *address, const char *name);
+--- bluez-5.11.orig/tools/csr_usb.c
++++ bluez-5.11/tools/csr_usb.c
+@@ -29,6 +29,7 @@
+ #include <errno.h>
+ #include <ctype.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- bluez-5.11.orig/tools/hid2hci.c
++++ bluez-5.11/tools/hid2hci.c
+@@ -35,6 +35,8 @@
+ #include <string.h>
+ #include <dirent.h>
+ #include <getopt.h>
++#include <limits.h>
++#include <sys/types.h>
+ #include <sys/ioctl.h>
+ #include <linux/types.h>
+ #include <linux/hiddev.h>
+--- bluez-5.11.orig/unit/test-sdp.c
++++ bluez-5.11/unit/test-sdp.c
+@@ -134,6 +134,10 @@
+ {
+ }
+
++void error(const char *format, ...)
++{
++}
++
+ static void context_quit(struct context *context)
+ {
+ g_main_loop_quit(context->main_loop);
+--- bluez-5.11.orig/src/systemd.c
++++ bluez-5.11/src/systemd.c
+@@ -30,6 +30,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <stddef.h>
++#include <string.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+