aboutsummaryrefslogtreecommitdiffstats
path: root/main/bridge-utils
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 12:57:11 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-15 20:27:22 +0000
commit857e995d257d2bee8023d2ab1cb6f2cad6f24049 (patch)
tree68f620ddbd7f517b68538d5eab43a3260d1c5cc4 /main/bridge-utils
parent0f01d2b19857158a8e9c93956d2690ae844c346e (diff)
downloadaports-857e995d257d2bee8023d2ab1cb6f2cad6f24049.tar.bz2
aports-857e995d257d2bee8023d2ab1cb6f2cad6f24049.tar.xz
main/bridge-utils: upgrade to 1.6 and modernize
Diffstat (limited to 'main/bridge-utils')
-rw-r--r--main/bridge-utils/00-musl-headers.patch53
-rw-r--r--main/bridge-utils/APKBUILD46
2 files changed, 13 insertions, 86 deletions
diff --git a/main/bridge-utils/00-musl-headers.patch b/main/bridge-utils/00-musl-headers.patch
deleted file mode 100644
index a9707318e1..0000000000
--- a/main/bridge-utils/00-musl-headers.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/brctl/brctl.c b/brctl/brctl.c
-index 454b8dd..8a7f095 100644
---- a/brctl/brctl.c
-+++ b/brctl/brctl.c
-@@ -19,7 +19,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <getopt.h>
-
- #include "libbridge.h"
-diff --git a/libbridge/libbridge.h b/libbridge/libbridge.h
-index 39964f2..73de4fb 100644
---- a/libbridge/libbridge.h
-+++ b/libbridge/libbridge.h
-@@ -23,6 +23,9 @@
- #include <linux/if.h>
- #include <linux/if_bridge.h>
-
-+#include <sys/types.h>
-+#include <sys/time.h>
-+
- /* defined in net/if.h but that conflicts with linux/if.h... */
- extern unsigned int if_nametoindex (const char *__ifname);
- extern char *if_indextoname (unsigned int __ifindex, char *__ifname);
-diff --git a/libbridge/libbridge_devif.c b/libbridge/libbridge_devif.c
-index aa8bc36..1da3549 100644
---- a/libbridge/libbridge_devif.c
-+++ b/libbridge/libbridge_devif.c
-@@ -23,7 +23,7 @@
- #include <errno.h>
- #include <string.h>
- #include <dirent.h>
--#include <sys/fcntl.h>
-+#include <fcntl.h>
-
- #include "libbridge.h"
- #include "libbridge_private.h"
-diff --git a/libbridge/libbridge_if.c b/libbridge/libbridge_if.c
-index 77d3f8a..9cf4bac 100644
---- a/libbridge/libbridge_if.c
-+++ b/libbridge/libbridge_if.c
-@@ -20,7 +20,7 @@
- #include <stdlib.h>
- #include <errno.h>
- #include <string.h>
--#include <sys/fcntl.h>
-+#include <fcntl.h>
- #include <sys/ioctl.h>
-
- #include "libbridge.h"
diff --git a/main/bridge-utils/APKBUILD b/main/bridge-utils/APKBUILD
index 7910e305f9..6a10d79424 100644
--- a/main/bridge-utils/APKBUILD
+++ b/main/bridge-utils/APKBUILD
@@ -1,54 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bridge-utils
-pkgver=1.5
-pkgrel=5
+pkgver=1.6
+pkgrel=0
pkgdesc="Tools for configuring the Linux kernel 802.1d Ethernet Bridge"
-url="http://sourceforge.net/projects/bridge/"
+url="https://www.kernel.org/pub/linux/utils/net/bridge-utils/"
arch="all"
license="GPL2+"
subpackages="$pkgname-doc"
depends=""
makedepends="autoconf linux-headers"
-source="http://downloads.sourceforge.net/project/bridge/bridge/bridge-utils-$pkgver.tar.gz
- 00-musl-headers.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "${_builddir}" || return 1
- for p in $source; do
- case $p in
- *.patch)
- msg $p; patch -p1 -i "$srcdir"/$p || return 1
- ;;
- esac
- done
-}
+source="https://www.kernel.org/pub/linux/utils/net/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
- autoconf || return 1
+ cd "$builddir"
+ autoconf
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
--libdir=/usr/lib \
- --includedir=/usr/include \
- || return 1
- make || return 1
- test -x brctl/brctl || return 1
+ --includedir=/usr/include
+ make
+ test -x brctl/brctl
}
package() {
- cd "$_builddir"
- make install DESTDIR="$pkgdir" || return 1
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
}
-md5sums="ec7b381160b340648dede58c31bb2238 bridge-utils-1.5.tar.gz
-0835358641d481269ab6a5b2fb186060 00-musl-headers.patch"
-sha256sums="42f9e5fb8f6c52e63a98a43b81bd281c227c529f194913e1c51ec48a393b6688 bridge-utils-1.5.tar.gz
-8cf2f4b57604a8287b9103430ce40dfefa3bd48e8bbca6a08299b03924c58557 00-musl-headers.patch"
-sha512sums="4e525fbd3defb509664ef3b728d9e5edfb92beaebdb5d7733d8203fb38cb3f4bb54d02dc1e28813889a2ee19c78b9b47da6d99c8032481a7fd7f104658dea7c3 bridge-utils-1.5.tar.gz
-12d8e736bb854c33c3bfcc8fc0d32e721c6655c5aed1e4a0f368c93fb06b6d0f5090a8b19a8527cb1a824747ee6d9f9df788a35dcf955e63e7c45c1bae0f48fe 00-musl-headers.patch"
+sha512sums="b2ed39bc67349b7b91f2068cb505c0e3c89a8797d61e3d97ff957796cfe5fcef2c26dd788bd4215f628d69a4c8592377f4e632c3e181e87af3eaa238d8741e02 bridge-utils-1.6.tar.xz"