aboutsummaryrefslogtreecommitdiffstats
path: root/main/brlaser
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-07-14 11:30:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-14 11:30:10 +0000
commit12f59500076a9e6cb9bce23888c124f2467f7aee (patch)
tree4803b556549a6f35d63377b66223b2920879ccdc /main/brlaser
parent474f67875434195713c19e5365c9b37e11e87351 (diff)
downloadaports-12f59500076a9e6cb9bce23888c124f2467f7aee.tar.bz2
aports-12f59500076a9e6cb9bce23888c124f2467f7aee.tar.xz
main/brlaser: upgrade to 3
Diffstat (limited to 'main/brlaser')
-rw-r--r--main/brlaser/APKBUILD16
-rw-r--r--main/brlaser/brlaser-v2-to-9c4336.patch51
2 files changed, 6 insertions, 61 deletions
diff --git a/main/brlaser/APKBUILD b/main/brlaser/APKBUILD
index 55faba4e9c..dee062549e 100644
--- a/main/brlaser/APKBUILD
+++ b/main/brlaser/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Isaac Dunham <ibid.ag@gmail.com>
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=brlaser
-pkgver=2
-pkgrel=1
+pkgver=3
+pkgrel=0
pkgdesc="Driver for Brother printers like the DCP 7030 and DCP 7065"
url="http://github.com/pdewacht/brlaser"
arch="all"
@@ -12,8 +12,7 @@ depends_dev=""
makedepends="$depends_dev cups-dev automake autoconf"
install=""
subpackages="$pkgname-doc"
-source="brlaser-$pkgver.tar.gz::https://github.com/pdewacht/brlaser/archive/v$pkgver.tar.gz
- brlaser-v2-to-9c4336.patch"
+source="brlaser-$pkgver.tar.gz::https://github.com/pdewacht/brlaser/archive/v$pkgver.tar.gz"
_builddir="$srcdir"/brlaser-$pkgver
prepare() {
@@ -46,9 +45,6 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="34bc664707dcd51e96a3b79917bcb50d brlaser-2.tar.gz
-4f547141394e3f5a5dc4e1b0b5aa2d49 brlaser-v2-to-9c4336.patch"
-sha256sums="20852bb99004474c25885b7d7ba124b079e7ea6beb277a85500641ca34fe24c6 brlaser-2.tar.gz
-62b24b19090aa1846b0958ed94f8841aee1c6eb884286cefc96100acc69ee003 brlaser-v2-to-9c4336.patch"
-sha512sums="eda631fd4cf80e3dd0f7097b62fd8e73f8adcafdfad937b49b5515d4ede37bcb861fa8a69397cacc3634baf18551a06bf2feb85042e34432ee26e695b7b8339b brlaser-2.tar.gz
-b6952e15ccf47fe65df75a9796ba67f5e65c5b9980f91da8324a9cc82b7a87790609bf6ecaf83bc8b574d771933d3a0aa79fb29a1141171f3342e686885ce962 brlaser-v2-to-9c4336.patch"
+md5sums="89bc6a86770baa06aa96f21e588819ee brlaser-3.tar.gz"
+sha256sums="495059a3b93c9c7106f2f72b2d646b0ee794a6527120a8936cd493752250b2ee brlaser-3.tar.gz"
+sha512sums="79c4709e0db48fc4b359297f44c2ad35633e65210fdb941aea7a9a613de4d341319aaa7e72748f7ed821400c564b9a5c63677692103130e3a6ec5ff938e0cccf brlaser-3.tar.gz"
diff --git a/main/brlaser/brlaser-v2-to-9c4336.patch b/main/brlaser/brlaser-v2-to-9c4336.patch
deleted file mode 100644
index e648a9b8b6..0000000000
--- a/main/brlaser/brlaser-v2-to-9c4336.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/README.md b/README.md
-index 585a42e..da4cb95 100644
---- a/README.md
-+++ b/README.md
-@@ -1,23 +1,15 @@
--"brlaser" Brother DCP-7030 printer driver
-+Driver for (some) Brother laster printers
- =========================================
-
--This is a driver for the Brother DCP-7030 laser printer. It might also
--be worth trying if you have some other old Brother monochrome laser
--printer.
-+Most Brother printers support a standard printer language such as PCL
-+or PostScript, but not all do. If you have a monochrome Brother laser
-+printer (or multi-function device) and the other open source drivers
-+don't work, this one might help.
-
--Currently this printer is not supported by other free software
--drivers. Ghostscript's hl1250 driver almost works, but has glitches
--with some fonts. (That driver tries to use PCL emulation, but that
--seems to be buggy on this printer. The proprietary driver never uses
--that mode.)
-+It is known to support these printers:
-
--Brother provides a non-free x86-only driver.
--
--Requirements
--------------
--
--* CUPS: tested with version 1.6.
--* A C++11 compiler: GCC 4.6 or later, or a recent version of Clang.
-+* Brother DCP-7030
-+* Brother DCP-7065DN
-
- Copyright
- ---------
-diff --git a/brlaser.drv.in b/brlaser.drv.in
-index 90846a3..364c319 100644
---- a/brlaser.drv.in
-+++ b/brlaser.drv.in
-@@ -81,3 +81,10 @@ Option "brlaserEconomode/Toner save mode" Boolean AnySetup 10
- Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-7030;CLS:PRINTER;"
- PCFileName "br7030.ppd"
- }
-+
-+{
-+ ModelName "DCP-7065DN"
-+ Attribute "NickName" "" "Brother DCP-7065DN, using @PACKAGE@ v@VERSION@"
-+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-7065DN;CLS:PRINTER;CID:Brother Laser Type1;"
-+ PCFileName "br7065dn.ppd"
-+}