aboutsummaryrefslogtreecommitdiffstats
path: root/main/brlaser
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-07-04 03:45:39 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-03 10:05:34 +0000
commit50512a6eec19677f4e973525b994f77adde6d1ea (patch)
tree84f3750754bb5140e5fb3a814d8bfd86800003f4 /main/brlaser
parentc5471bd6117c8bee76fcd8a0ecf89f584420997c (diff)
downloadaports-50512a6eec19677f4e973525b994f77adde6d1ea.tar.bz2
aports-50512a6eec19677f4e973525b994f77adde6d1ea.tar.xz
main/brlaser: update from upstream git.
Upstream has updated the documentation and brlaser.drv to indicate support for the Brother DCP 7065DN
Diffstat (limited to 'main/brlaser')
-rw-r--r--main/brlaser/APKBUILD16
-rw-r--r--main/brlaser/brlaser-v2-to-9c4336.patch51
2 files changed, 61 insertions, 6 deletions
diff --git a/main/brlaser/APKBUILD b/main/brlaser/APKBUILD
index 064695a93d..55faba4e9c 100644
--- a/main/brlaser/APKBUILD
+++ b/main/brlaser/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=brlaser
pkgver=2
-pkgrel=0
-pkgdesc="Driver for Brother DCP 7030 and DCP 7065 printers"
+pkgrel=1
+pkgdesc="Driver for Brother printers like the DCP 7030 and DCP 7065"
url="http://github.com/pdewacht/brlaser"
arch="all"
license="GPL2+"
@@ -12,7 +12,8 @@ depends_dev=""
makedepends="$depends_dev cups-dev automake autoconf"
install=""
subpackages="$pkgname-doc"
-source="brlaser-$pkgver.tar.gz::https://github.com/pdewacht/brlaser/archive/v$pkgver.tar.gz"
+source="brlaser-$pkgver.tar.gz::https://github.com/pdewacht/brlaser/archive/v$pkgver.tar.gz
+ brlaser-v2-to-9c4336.patch"
_builddir="$srcdir"/brlaser-$pkgver
prepare() {
@@ -45,6 +46,9 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="34bc664707dcd51e96a3b79917bcb50d brlaser-2.tar.gz"
-sha256sums="20852bb99004474c25885b7d7ba124b079e7ea6beb277a85500641ca34fe24c6 brlaser-2.tar.gz"
-sha512sums="eda631fd4cf80e3dd0f7097b62fd8e73f8adcafdfad937b49b5515d4ede37bcb861fa8a69397cacc3634baf18551a06bf2feb85042e34432ee26e695b7b8339b brlaser-2.tar.gz"
+md5sums="34bc664707dcd51e96a3b79917bcb50d brlaser-2.tar.gz
+4f547141394e3f5a5dc4e1b0b5aa2d49 brlaser-v2-to-9c4336.patch"
+sha256sums="20852bb99004474c25885b7d7ba124b079e7ea6beb277a85500641ca34fe24c6 brlaser-2.tar.gz
+62b24b19090aa1846b0958ed94f8841aee1c6eb884286cefc96100acc69ee003 brlaser-v2-to-9c4336.patch"
+sha512sums="eda631fd4cf80e3dd0f7097b62fd8e73f8adcafdfad937b49b5515d4ede37bcb861fa8a69397cacc3634baf18551a06bf2feb85042e34432ee26e695b7b8339b brlaser-2.tar.gz
+b6952e15ccf47fe65df75a9796ba67f5e65c5b9980f91da8324a9cc82b7a87790609bf6ecaf83bc8b574d771933d3a0aa79fb29a1141171f3342e686885ce962 brlaser-v2-to-9c4336.patch"
diff --git a/main/brlaser/brlaser-v2-to-9c4336.patch b/main/brlaser/brlaser-v2-to-9c4336.patch
new file mode 100644
index 0000000000..e648a9b8b6
--- /dev/null
+++ b/main/brlaser/brlaser-v2-to-9c4336.patch
@@ -0,0 +1,51 @@
+diff --git a/README.md b/README.md
+index 585a42e..da4cb95 100644
+--- a/README.md
++++ b/README.md
+@@ -1,23 +1,15 @@
+-"brlaser" Brother DCP-7030 printer driver
++Driver for (some) Brother laster printers
+ =========================================
+
+-This is a driver for the Brother DCP-7030 laser printer. It might also
+-be worth trying if you have some other old Brother monochrome laser
+-printer.
++Most Brother printers support a standard printer language such as PCL
++or PostScript, but not all do. If you have a monochrome Brother laser
++printer (or multi-function device) and the other open source drivers
++don't work, this one might help.
+
+-Currently this printer is not supported by other free software
+-drivers. Ghostscript's hl1250 driver almost works, but has glitches
+-with some fonts. (That driver tries to use PCL emulation, but that
+-seems to be buggy on this printer. The proprietary driver never uses
+-that mode.)
++It is known to support these printers:
+
+-Brother provides a non-free x86-only driver.
+-
+-Requirements
+-------------
+-
+-* CUPS: tested with version 1.6.
+-* A C++11 compiler: GCC 4.6 or later, or a recent version of Clang.
++* Brother DCP-7030
++* Brother DCP-7065DN
+
+ Copyright
+ ---------
+diff --git a/brlaser.drv.in b/brlaser.drv.in
+index 90846a3..364c319 100644
+--- a/brlaser.drv.in
++++ b/brlaser.drv.in
+@@ -81,3 +81,10 @@ Option "brlaserEconomode/Toner save mode" Boolean AnySetup 10
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-7030;CLS:PRINTER;"
+ PCFileName "br7030.ppd"
+ }
++
++{
++ ModelName "DCP-7065DN"
++ Attribute "NickName" "" "Brother DCP-7065DN, using @PACKAGE@ v@VERSION@"
++ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-7065DN;CLS:PRINTER;CID:Brother Laser Type1;"
++ PCFileName "br7065dn.ppd"
++}