aboutsummaryrefslogtreecommitdiffstats
path: root/main/bubblewrap
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-28 22:19:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-28 23:02:58 +0100
commitb32dbd27573f4ec376e904f96d0f3bc1657014c0 (patch)
tree919353f6643367a806167db02c817c27694da64d /main/bubblewrap
parentce1aaab83e0bbcf24fed4b24f534b8d376b45553 (diff)
downloadaports-b32dbd27573f4ec376e904f96d0f3bc1657014c0.tar.bz2
aports-b32dbd27573f4ec376e904f96d0f3bc1657014c0.tar.xz
main/bubblewrap: upgrade to 0.4.0
Diffstat (limited to 'main/bubblewrap')
-rw-r--r--main/bubblewrap/APKBUILD13
-rw-r--r--main/bubblewrap/musl-fixes.patch17
2 files changed, 4 insertions, 26 deletions
diff --git a/main/bubblewrap/APKBUILD b/main/bubblewrap/APKBUILD
index b4ef42d4d7..d4c951c85e 100644
--- a/main/bubblewrap/APKBUILD
+++ b/main/bubblewrap/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=bubblewrap
-pkgver=0.3.3
+pkgver=0.4.0
pkgrel=0
pkgdesc="Unprivileged sandboxing tool"
url="https://github.com/projectatomic/bubblewrap"
@@ -12,17 +12,14 @@ makedepends="autoconf automake libcap-dev docbook-xsl"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="bubblewrap-$pkgver.tar.gz::https://github.com/projectatomic/bubblewrap/archive/v$pkgver.tar.gz
realpath-workaround.patch
- musl-fixes.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+ "
prepare() {
- cd "$builddir"
NOCONFIGURE=1 ./autogen.sh
default_prepare
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,7 +32,6 @@ build() {
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
}
@@ -48,6 +44,5 @@ bashcomp() {
mv "$pkgdir"/usr/share/bash-completion/ "$subpkgdir"/usr/share/
}
-sha512sums="b1c38fad90ddaa23a5f2dd49f9ec3f9d9af7426af321ae9f7c43dd64f11a448b3502942a42112a1c6ebf8a4dea2e1196b17c31cca9c2f119dc2e0c1674c345ae bubblewrap-0.3.3.tar.gz
-7e8395aa7801263056b0c072194240f0ae1ee1a3b0acd874baf112a7b7b5e53ac5f688ece9099067bfc1e28e52e81f107964a3288a615cc1eedb1af5f82bbd8e realpath-workaround.patch
-f59cda3b09dd99db9ca6d97099a15bb2523e054063d677502317ae3165ba2e32105a0ae8f877afc3827bd28d093c9d9d413270f4c87d9fe5f26f3eee670d916e musl-fixes.patch"
+sha512sums="1957126e13900bbb1c9c885802f513006313836826938555899a8ad0e6c3ba47478eae0cc90f4aceff228663379b45203dce4fa57d6bfc489984670571232b97 bubblewrap-0.4.0.tar.gz
+7e8395aa7801263056b0c072194240f0ae1ee1a3b0acd874baf112a7b7b5e53ac5f688ece9099067bfc1e28e52e81f107964a3288a615cc1eedb1af5f82bbd8e realpath-workaround.patch"
diff --git a/main/bubblewrap/musl-fixes.patch b/main/bubblewrap/musl-fixes.patch
deleted file mode 100644
index ecf6263310..0000000000
--- a/main/bubblewrap/musl-fixes.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/config.h.in
-+++ b/config.h.in
-@@ -102,3 +102,14 @@
-
- /* Define to 1 if you need to in order for `stat' and other things to work. */
- #undef _POSIX_SOURCE
-+
-+/* taken from glibc unistd.h and fixes musl */
-+#ifndef TEMP_FAILURE_RETRY
-+#define TEMP_FAILURE_RETRY(expression) \
-+ (__extension__ \
-+ ({ long int __result; \
-+ do __result = (long int) (expression); \
-+ while (__result == -1L && errno == EINTR); \
-+ __result; }))
-+#endif
-+