aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-28 16:16:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 16:16:03 +0000
commit0c1064dd88d91662b81862556556cee9f807abde (patch)
tree1f8047ba0892707ea4c3c67ba4de140007c0d3eb /main/busybox
parentc29bf7e28f2115166449d6a5d4feb66feb83f4e1 (diff)
downloadaports-0c1064dd88d91662b81862556556cee9f807abde.tar.bz2
aports-0c1064dd88d91662b81862556556cee9f807abde.tar.xz
main/busybox: fix patch for fsck
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch45
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 38 insertions, 11 deletions
diff --git a/main/busybox/0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch b/main/busybox/0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
index 323e079021..31d8e3f89d 100644
--- a/main/busybox/0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
+++ b/main/busybox/0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
@@ -1,14 +1,14 @@
-From 549b5fa1384bb29c3ea92486539dccd9a7d71b83 Mon Sep 17 00:00:00 2001
+From 54f76ba53e22fdbc9efebe8b42dd121ec3126fef Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Tue, 28 Nov 2017 13:23:17 +0100
Subject: [PATCH] fsck: resolve LABEL=.../UUID=... spec to device
---
- e2fsprogs/fsck.c | 2 ++
- 1 file changed, 2 insertions(+)
+ e2fsprogs/fsck.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/e2fsprogs/fsck.c b/e2fsprogs/fsck.c
-index eb53002b1..2adf0cf07 100644
+index eb53002b1..338701c6a 100644
--- a/e2fsprogs/fsck.c
+++ b/e2fsprogs/fsck.c
@@ -60,6 +60,7 @@
@@ -19,14 +19,41 @@ index eb53002b1..2adf0cf07 100644
#include "common_bufsiz.h"
/* "progress indicator" code is somewhat buggy and ext[23] specific.
-@@ -976,6 +977,7 @@ int fsck_main(int argc UNUSED_PARAM, char **argv)
- // "/path", "UUID=xxx" or "LABEL=xxx" into block device name
- // ("UUID=xxx"/"LABEL=xxx" can probably shifted to fsck.auto duties)
+@@ -523,12 +524,13 @@ static int wait_many(int flags)
+ * Execute a particular fsck program, and link it into the list of
+ * child processes we are waiting for.
+ */
+-static void execute(const char *type, const char *device,
++static void execute(const char *type, const char *spec,
+ const char *mntpt /*, int interactive */)
+ {
+ int i;
+ struct fsck_instance *inst;
+ pid_t pid;
++ char *device = (char *)spec;
+
+ G.args[0] = xasprintf("fsck.%s", type);
+
+@@ -543,7 +545,8 @@ static void execute(const char *type, const char *device,
+ }
+ #endif
+
+- G.args[G.num_args - 2] = (char*)device;
++ resolve_mount_spec(&device);
++ G.args[G.num_args - 2] = device;
+ /* G.args[G.num_args - 1] = NULL; - already is */
+
+ if (G.verbose || G.noexecute) {
+@@ -972,9 +975,6 @@ int fsck_main(int argc UNUSED_PARAM, char **argv)
+
+ /* "/dev/blk" or "/path" or "UUID=xxx" or "LABEL=xxx" */
+ if ((arg[0] == '/' && !opts_for_fsck) || strchr(arg, '=')) {
+-// FIXME: must check that arg is a blkdev, or resolve
+-// "/path", "UUID=xxx" or "LABEL=xxx" into block device name
+-// ("UUID=xxx"/"LABEL=xxx" can probably shifted to fsck.auto duties)
devices = xrealloc_vector(devices, 2, num_devices);
-+ resolve_mount_spec(&arg);
devices[num_devices++] = arg;
continue;
- }
--
2.15.0
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index bcfc11e15e..23158dec81 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.27.2
-pkgrel=5
+pkgrel=6
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -185,7 +185,7 @@ static() {
sha512sums="d99e86b652562ebe1a5d50e1ba3877a1d1612997c17cb8d8e4212da181211a9b741a881cb051f14cb3ee8aea40226cf2cde80a076baed265d3bc0a4e96a5031c busybox-1.27.2.tar.bz2
dc08288c8e9e29d36be7174d58f3bee2d0508465977fb40d39807aa0b03149f7814f8cfed113d0a7589ef49890beb1805ef00f0d37b563447fe875e3cff08d1c 0001-ash-add-support-for-command_not_found_handle-hook-fu.patch
-26f48549dfd4bb0a948d6bff86f5a68106b1d005fd24de5e0f528925a4da0b9c5ebafc11070cbe456185eb94f9567afe6d6eba791c1d1f3fe5431a2a36a48abf 0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
+7904e47350ebad3f5370b0bca1b344a808cf4f1ae238686309a502bd675df7969eb76859c77ef81f709b0861173c9ca0181c5d5b8c3978e6149564384bb0c157 0001-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
1930775839354a63c30970f0d52d00cfd3a8f6b9f48d6de45ea7d2478d080bde7193c1c2cce026dc7337d9ecf0b65f5ff1dd4351c1eb195e6f0c0c5126f10511 0001-ash-exec-busybox.static.patch
a756aa89c4602cd091df0052e2e3d7b45a359fbfe953b70aa3029e3eeb8e5d1772cbf1525bb62df6ce6547f1e5605617195ddae336e1ffe41f5c58d524af6ba6 0002-app-location-for-cpio-vi-and-lspci.patch
fc17ce9b12726e3449518692bf0d4906c36f091534706b5b91c910866bd8cd50d8f7d4b449d54eeed24ee656012a6ef04612bf092874e4b83b0723f852fdce0e 0003-udhcpc-set-default-discover-retries-to-5.patch