aboutsummaryrefslogtreecommitdiffstats
path: root/main/bzip2
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 12:27:22 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 11:51:45 +0000
commitc6b22e221b6a7d6be255b6b15702612521e8e08e (patch)
tree60474e42baa1d5527b4962d269d83d916c794766 /main/bzip2
parented42c3c981c0b63bcd3999142952e609d0521889 (diff)
downloadaports-c6b22e221b6a7d6be255b6b15702612521e8e08e.tar.bz2
aports-c6b22e221b6a7d6be255b6b15702612521e8e08e.tar.xz
main/bzip2: modernize abuild
Diffstat (limited to 'main/bzip2')
-rw-r--r--main/bzip2/APKBUILD44
1 files changed, 9 insertions, 35 deletions
diff --git a/main/bzip2/APKBUILD b/main/bzip2/APKBUILD
index 4b05b80cf2..9e2d7e41ac 100644
--- a/main/bzip2/APKBUILD
+++ b/main/bzip2/APKBUILD
@@ -7,7 +7,6 @@ url="http://sources.redhat.com/bzip2"
arch="all"
license="BSD"
depends=""
-install=""
subpackages="$pkgname-dev $pkgname-doc libbz2"
source="http://www.bzip.org/$pkgver/$pkgname-$pkgver.tar.gz
bzip2-1.0.4-makefile-CFLAGS.patch
@@ -22,41 +21,32 @@ source="http://www.bzip.org/$pkgver/$pkgname-$pkgver.tar.gz
# secfixes:
# 1.0.6-r5: CVE-2016-3189
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
+ default_prepare
# Fix man path
# Generate relative symlinks
sed -i \
-e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
-e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
- Makefile || return 1
+ Makefile
# fixup broken version stuff
sed -i \
-e "s:1\.0\.4:$pkgver:" \
- bzip2.1 bzip2.txt Makefile-libbz2_so manual.* || return 1
+ bzip2.1 bzip2.txt Makefile-libbz2_so manual.*
}
build () {
- cd "$_builddir"
- make -f Makefile-libbz2_so all || return 1
- make all || return 1
+ cd "$builddir"
+ make -f Makefile-libbz2_so all
+ make all
}
package() {
- cd "$_builddir"
- make PREFIX="$pkgdir"/usr install || return 1
+ cd "$builddir"
+ make PREFIX="$pkgdir"/usr install
install -D libbz2.so.$pkgver "$pkgdir"/usr/lib/libbz2.so.$pkgver
ln -s libbz2.so.$pkgver "$pkgdir"/usr/lib/libbz2.so
ln -s libbz2.so.$pkgver "$pkgdir"/usr/lib/libbz2.so.${pkgver%%.*}
@@ -68,22 +58,6 @@ libbz2() {
mv "$pkgdir"/usr/lib/*.so.* "$subpkgdir"/usr/lib/
}
-md5sums="00b516f4704d4a7cb50a1d97e6e8e15b bzip2-1.0.6.tar.gz
-3675cd4db6affe64e1d7d40bc2ad4f26 bzip2-1.0.4-makefile-CFLAGS.patch
-d47a4aa8f08d101aa5aa0dd2030338d1 bzip2-1.0.6-saneso.patch
-fd13ef6bc55276c7e3adc346bde56cd1 bzip2-1.0.4-man-links.patch
-5f7a98f0aaaed6554126d30e28383ee0 bzip2-1.0.2-progress.patch
-804bd17c96297968a89fc4eddc9a6713 bzip2-1.0.3-no-test.patch
-55ac0e9be7821190b99376e0205707be bzip2-1.0.4-POSIX-shell.patch
-bb267d21004b2e756a18c3b5f31a8257 CVE-2016-3189.patch"
-sha256sums="a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd bzip2-1.0.6.tar.gz
-8b625c4a37395ef94b19854b6a43f7e756edc3e238924669bc01d858853a1703 bzip2-1.0.4-makefile-CFLAGS.patch
-5591ef4d3ccc1ea08750ce5650efadb0e8e2255b50e506cc8d66b131f8d891f2 bzip2-1.0.6-saneso.patch
-1fc9d91f3f7bd3eecd86149b9c95b3162d9d7956f7de543aa8bc41cbcd04f88b bzip2-1.0.4-man-links.patch
-a76f6d082a1a1fef2eff111177d7c7568e1d457fb2b98cde71bbbe6ea1c7c787 bzip2-1.0.2-progress.patch
-3478e797662d85996c03d3b7612d548d2d377fe7efc3dc190332741a11082ef6 bzip2-1.0.3-no-test.patch
-a810bda8ff824a3da6c5eb2659e388c6f6d8b7f09d08ca5b3ace18f96d5299fe bzip2-1.0.4-POSIX-shell.patch
-b47515cf71a5773c5e26aa4faf1486d3a60de127cb99cdc0c6aee229d362ae7c CVE-2016-3189.patch"
sha512sums="00ace5438cfa0c577e5f578d8a808613187eff5217c35164ffe044fbafdfec9e98f4192c02a7d67e01e5a5ccced630583ad1003c37697219b0f147343a3fdd12 bzip2-1.0.6.tar.gz
58cc37430555520b6e35db2740e699cf37eacdd82989c21a222a593e36288710a0defb003662d4238235c12b3764bfc89cd646e6be9d0a08d54bd2c9baa6ad15 bzip2-1.0.4-makefile-CFLAGS.patch
8a7528b5b931bb72f637c6940bc811d54fb816fd5bb453af56d9b4a87091004eb5e191ba799d972794b24c56cf8134344a618b58946d3f1d985c508f88190845 bzip2-1.0.6-saneso.patch