aboutsummaryrefslogtreecommitdiffstats
path: root/main/check
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-23 13:10:05 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-23 13:10:45 +0200
commit5669a06decf0c081ddc727b3dc4fe4ff07d557a0 (patch)
tree86a480604433fb40662aea90d1f283fa55d0a50d /main/check
parent60308513b516a64047f4170e887d6f4bafc11bed (diff)
downloadaports-5669a06decf0c081ddc727b3dc4fe4ff07d557a0.tar.bz2
aports-5669a06decf0c081ddc727b3dc4fe4ff07d557a0.tar.xz
main/check: disable tests and reorder subpkgs
https://github.com/libcheck/check/issues/138 reorder to catch all docs in doc subpkg
Diffstat (limited to 'main/check')
-rw-r--r--main/check/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index b4a09cfa06..ad9506c80d 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -8,7 +8,10 @@ url="https://libcheck.github.io/check/"
arch="all"
license="LGPL2+"
makedepends="pkgconfig"
-subpackages="$pkgname-dev $pkgname-doc"
+# https://github.com/libcheck/check/issues/138
+options="!check"
+checkdepends="diffutils"
+subpackages="$pkgname-doc $pkgname-dev"
source="https://github.com/libcheck/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
@@ -25,6 +28,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install