aboutsummaryrefslogtreecommitdiffstats
path: root/main/check
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-28 17:57:48 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-28 17:58:17 +0200
commita7936f603c94c3d76fda0abec6570b4d1d2a44a2 (patch)
tree34df3d8fb854464ec088073cd3e1ad0eb1dbaf0d /main/check
parent5c090d6b334c062bb727100e68012fc752d1368a (diff)
downloadaports-a7936f603c94c3d76fda0abec6570b4d1d2a44a2.tar.bz2
aports-a7936f603c94c3d76fda0abec6570b4d1d2a44a2.tar.xz
main/check: disable forking
https://github.com/libcheck/check/issues/138
Diffstat (limited to 'main/check')
-rw-r--r--main/check/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index ad9506c80d..1aa9a12719 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -2,15 +2,13 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=check
pkgver=0.12.0
-pkgrel=0
+pkgrel=1
pkgdesc="A unit test framework for C"
url="https://libcheck.github.io/check/"
arch="all"
license="LGPL2+"
makedepends="pkgconfig"
-# https://github.com/libcheck/check/issues/138
-options="!check"
-checkdepends="diffutils"
+checkdepends="diffutils gawk"
subpackages="$pkgname-doc $pkgname-dev"
source="https://github.com/libcheck/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
@@ -18,13 +16,16 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+ # NOTE: disabled forking due to hardened
+ # https://github.com/libcheck/check/issues/138
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-fork
make
}