aboutsummaryrefslogtreecommitdiffstats
path: root/main/check
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-28 22:55:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-29 00:22:24 +0100
commitbb0f76d2694e733199699699283ad716682efe5e (patch)
tree00844e978eb697bca9f456d75ff32e801ffa4867 /main/check
parent0dd85004fcd087e69dd70d2f9c1123f2bf885cc4 (diff)
downloadaports-bb0f76d2694e733199699699283ad716682efe5e.tar.bz2
aports-bb0f76d2694e733199699699283ad716682efe5e.tar.xz
main/check: upgrade to 0.14.0
Diffstat (limited to 'main/check')
-rw-r--r--main/check/APKBUILD12
-rw-r--r--main/check/do-not-check-for-tex.patch23
2 files changed, 3 insertions, 32 deletions
diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index 0b6c5bc691..123db2c85c 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=check
-pkgver=0.13.0
+pkgver=0.14.0
pkgrel=0
pkgdesc="A unit test framework for C"
url="https://libcheck.github.io/check/"
@@ -10,17 +10,14 @@ license="LGPL-2.0-or-later"
makedepends="pkgconfig texinfo autoconf automake libtool"
checkdepends="diffutils gawk"
subpackages="$pkgname-doc $pkgname-dev"
-source="https://github.com/libcheck/check/releases/download/$pkgver/check-$pkgver.tar.gz
- do-not-check-for-tex.patch"
+source="https://github.com/libcheck/check/releases/download/$pkgver/check-$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
autoreconf -vfi
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,14 +30,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="9e3a3b4b2e1aae02f6481a3d944a5a9216c1f03d85a2bbd63c05d047095fe16b78e5c4094b464fe531650daba24c58d7343f7ec059ce0e127e9aff1ff86213d0 check-0.13.0.tar.gz
-79b421a3154f904350352a787801b4db337bd7fed728e613ee2aad8fc9cdbcfbf2c7ec476a2753780a773a3cb3b54e9e7a4ae1d2ea4bd641e1dd6730d389b628 do-not-check-for-tex.patch"
+sha512sums="07fc85b5eecffeb407f554c0cb737126ed6d68ba0db3d74c14697505f2b410496ff72311f08bbf43d7af1c971f0475e776966e320bfb3fe00cde1ecbe1d6f367 check-0.14.0.tar.gz"
diff --git a/main/check/do-not-check-for-tex.patch b/main/check/do-not-check-for-tex.patch
deleted file mode 100644
index 50b7b8e9d9..0000000000
--- a/main/check/do-not-check-for-tex.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Starting with check 0.13.0, check incorrectly checks for the tex instead
-of the makeinfo command for building documentation.
-
-See:
-
- * https://github.com/libcheck/check/issues/206
- * https://github.com/libcheck/check/pull/212
-
-Without this change documentation files (the info page and example code)
-which were previously installed are no longer installed.
-
-diff -upr check-0.13.0.orig/configure.ac check-0.13.0/configure.ac
---- check-0.13.0.orig/configure.ac 2019-10-25 17:17:54.361921908 +0200
-+++ check-0.13.0/configure.ac 2019-10-25 17:18:13.101931933 +0200
-@@ -182,7 +182,7 @@ AC_CHECK_PROGS(LCOV, lcov, false)
- AC_CHECK_PROGS(GENHTML, genhtml, false)
-
- if test "xtrue" = x"$enable_build_docs"; then
-- AC_CHECK_PROGS(TEX, tex, false)
-+ AC_CHECK_PROGS(TEX, makeinfo, false)
- if test "$TEX" = "false"; then
- # Make it [somewhat] clear to maintainers that tex is missing. Not an error
- # though because 'make install' (which users need) does not build the docs