aboutsummaryrefslogtreecommitdiffstats
path: root/main/checkbashisms
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-12-30 12:12:06 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-02 16:11:45 +0000
commit77fd3bff97cc1b7ba6c501f1dd93c16bf8354661 (patch)
tree10f4e450bc4fa94d9d6564c88c255c0bd6ae1683 /main/checkbashisms
parentfa01d4496c2bb0003b172d926753f5c12f6ea6a8 (diff)
downloadaports-77fd3bff97cc1b7ba6c501f1dd93c16bf8354661.tar.bz2
aports-77fd3bff97cc1b7ba6c501f1dd93c16bf8354661.tar.xz
main/checkbashisms: new version 2.17.11
Change to Debian devscripts as upstream. Drop patch included in upstream Package the manpage as well
Diffstat (limited to 'main/checkbashisms')
-rw-r--r--main/checkbashisms/APKBUILD27
-rw-r--r--main/checkbashisms/checkbashisms-perl-5.26.patch20
2 files changed, 11 insertions, 36 deletions
diff --git a/main/checkbashisms/APKBUILD b/main/checkbashisms/APKBUILD
index b0d95b85a3..8f851095df 100644
--- a/main/checkbashisms/APKBUILD
+++ b/main/checkbashisms/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=checkbashisms
-pkgver=2.0.0.2
-pkgrel=5
+pkgver=2.17.11
+pkgrel=0
pkgdesc="Basic checks on shell scripts for the presence of non portable syntax"
-url="https://sourceforge.net/projects/checkbaskisms/"
+subpackages="$pkgname-doc"
+url="http://cdn.debian.net/debian/pool/main/d/devscripts/"
arch="noarch"
license="GPL-2.0"
depends="perl"
-source="http://downloads.sourceforge.net/project/checkbaskisms/$pkgver/checkbashisms
- checkbashisms-perl-5.26.patch"
+source="http://cdn.debian.net/debian/pool/main/d/devscripts/devscripts_$pkgver.tar.xz"
-builddir="$srcdir"
+builddir="$srcdir/devscripts-$pkgver/scripts"
check() {
cd "$builddir"
@@ -20,20 +20,15 @@ check() {
}
prepare() {
- cd "$builddir"
-
- # can not patch a symlink
- src=$(realpath checkbashisms)
- rm "$pkgname"
- cp "$src" "$pkgname"
-
default_prepare
+ mv "$pkgname".pl "$pkgname"
+ sed -i "s/###VERSION###/$pkgver/" "$pkgname"
}
package() {
cd "$builddir"
- install -D -m755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -D -m755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -D -m755 "$pkgname".1 "$pkgdir/usr/share/man/man1/$pkgname".1
}
-sha512sums="cd9376f4c34773aba79f81b8bb129d912844102e91e363480b9983092efd36c4827e0447242aecfcdb3cfd4cc50e19e105cc645368e8c9735f49c8e381964dd4 checkbashisms
-78ef7c52748e3aee4202b316ee22a67b17024fecbdd0e9008a6e68348bf0454a362ed728da550799ffbed4ad916735cef965e9dd83a7d69af257710fbd69d69a checkbashisms-perl-5.26.patch"
+sha512sums="bcce427b551ba1ee19b794e4a8243ae6c8efdf7fb6f108b7cd0e43a93ce9a12bee99800fc40c2b8a2bbf6451adceaeadf6042752fa2e404cad2d014ff03474bf devscripts_2.17.11.tar.xz"
diff --git a/main/checkbashisms/checkbashisms-perl-5.26.patch b/main/checkbashisms/checkbashisms-perl-5.26.patch
deleted file mode 100644
index baea1b1707..0000000000
--- a/main/checkbashisms/checkbashisms-perl-5.26.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/checkbashisms 2017-08-28 08:42:38.000000000 +0200
-+++ b/checkbashisms 2017-09-08 19:47:57.154908415 +0200
-@@ -440,7 +440,7 @@
- # Finally the whole subexpression may be omitted for scripts
- # which do not pass on their parameters (i.e. after re-execing
- # they take their parameters (and potentially data) from stdin
-- .?(\${1:?\+.?)?(\$(\@|\*))?~x) {
-+ .?(\$[{]1:?\+.?)?(\$(\@|\*))?~x) {
- $ret = $. - 1;
- last;
- } elsif (/^\s*(\w+)=\$0;/) {
-@@ -453,7 +453,7 @@
- # As above
- .?\$$var.?\s*
- (--\s*)?
-- .?(\${1:?\+.?)?(\$(\@|\*))?.?\s*\&~x) {
-+ .?(\$[{]1:?\+.?)?(\$(\@|\*))?.?\s*\&~x) {
-
- $backgrounded = 1;
- } elsif ($backgrounded and m~