aboutsummaryrefslogtreecommitdiffstats
path: root/main/cifs-utils
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 23:47:03 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 23:59:56 +0100
commitc976d8d3d926b062a07eec82bb4607d894ec5dc2 (patch)
tree85912956affc2ae8294e11bb405f141a9a3821fe /main/cifs-utils
parent567862695581b283682230e0d4a6461d2b3ef9b0 (diff)
downloadaports-c976d8d3d926b062a07eec82bb4607d894ec5dc2.tar.bz2
aports-c976d8d3d926b062a07eec82bb4607d894ec5dc2.tar.xz
main/cifs-utils: use py3-docutils
Diffstat (limited to 'main/cifs-utils')
-rw-r--r--main/cifs-utils/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/main/cifs-utils/APKBUILD b/main/cifs-utils/APKBUILD
index 89f6bd6ace..96497136cd 100644
--- a/main/cifs-utils/APKBUILD
+++ b/main/cifs-utils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=cifs-utils
pkgver=6.9
-pkgrel=0
+pkgrel=1
pkgdesc="CIFS filesystem user-space tools"
url="https://wiki.samba.org/index.php/LinuxCIFS_utils"
arch="all"
@@ -10,16 +10,20 @@ license="GPL-2.0-or-later"
makedepends="libcap-dev keyutils-dev krb5-dev talloc-dev
autoconf automake samba-dev py-docutils"
subpackages="$pkgname-doc $pkgname-dev"
-source="https://ftp.samba.org/pub/linux-cifs/$pkgname/$pkgname-$pkgver.tar.bz2
+source="https://ftp.samba.org/pub/linux-cifs/cifs-utils/cifs-utils-$pkgver.tar.bz2
musl-fix-includes.patch
xattr_size_max.patch"
-options=suid
+options="suid"
-builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -i
+}
build() {
- cd "$builddir"
- autoreconf -i
+ ln -s /usr/bin/rst2man-3 rst2man
+ export PATH="$PATH":.
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +32,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -r $pkgdir/usr/bin
# set mount.cifs uid, to enable none root mounting form fstab