aboutsummaryrefslogtreecommitdiffstats
path: root/main/cjdns/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-01-21 12:18:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-01-21 12:19:50 +0000
commit301fb793ca20f34727f6effd520878fd6cbd6852 (patch)
treecf114f659de1141517195662d997a5d3bb633b1e /main/cjdns/APKBUILD
parent018bfbb7446893787b33668b43c2585391f20a04 (diff)
downloadaports-301fb793ca20f34727f6effd520878fd6cbd6852.tar.bz2
aports-301fb793ca20f34727f6effd520878fd6cbd6852.tar.xz
main/cjdns: move back from unmaintained and upgrade to 20.5
upstream has tagged new release with python3 support https://github.com/hyperboria/bugs/issues/194#issuecomment-576645642
Diffstat (limited to 'main/cjdns/APKBUILD')
-rw-r--r--main/cjdns/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/main/cjdns/APKBUILD b/main/cjdns/APKBUILD
new file mode 100644
index 0000000000..486704a3ba
--- /dev/null
+++ b/main/cjdns/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+# Contributor: kpcyrd <git@rxv.cc>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=cjdns
+pkgver=20.5
+pkgrel=0
+pkgdesc="A routing engine designed for security, scalability, speed and ease of use"
+url="https://github.com/cjdelisle/cjdns"
+arch="all !x86 !s390x"
+license="GPL-3.0-or-later"
+makedepends="nodejs python3 linux-headers libseccomp-dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc $pkgname-openrc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cjdelisle/cjdns/archive/cjdns-v$pkgver.tar.gz
+ no-march-flag.patch"
+
+builddir="$srcdir/$pkgname-$pkgname-v$pkgver"
+
+build() {
+ cd "$builddir"
+ export CJDNS_RELEASE_VERSION="$pkgver"
+ node ./node_build/make.js
+}
+
+check() {
+ cd "$builddir"
+ ./cjdroute --help >/dev/null
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 cjdroute "$pkgdir/usr/sbin/cjdroute"
+ install -Dm755 contrib/openrc/cjdns "$pkgdir/etc/init.d/cjdns"
+ install -Dm644 doc/man/cjdroute.conf.5 \
+ "$pkgdir/usr/share/man/man5/cjdroute.conf.5"
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" \
+ doc/admin-api.md \
+ doc/configure.md \
+ doc/djc_layer_model.md \
+ doc/nat-gateway.md \
+ doc/network-services.md \
+ doc/non-root-user.md \
+ doc/security_specification.md \
+ doc/shorewall_and_vpn_gateway_howto.md \
+ doc/tunnel.md
+}
+
+sha512sums="36ae20182b9e9601ae64630cb0fa96caccbe5279be48520ea8b457a15437da5c9b48a5ae5588bd76ef819efe696b5a582a906a50e4dbe7760bb96fa7d1d63ea3 cjdns-20.5.tar.gz
+0c487a46609b75408d83cee954fc49f47997f0e9ee2bb8f64c3edc7e67273e5e90b4b2028847e09faa4bd1310b82f1a86fa7d0d0c42f18510cc9dcd4bccb8808 no-march-flag.patch"