aboutsummaryrefslogtreecommitdiffstats
path: root/main/clamav
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-02-16 02:30:07 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-02-16 02:30:11 +0000
commit376c27e55cf451f2783a38b8e67a08958f0be2b0 (patch)
tree1cc1b64e69964b578289e257d6ddc0c659d57233 /main/clamav
parent8f4fbdb510172d414d1f78fd08b013498c313cc3 (diff)
downloadaports-376c27e55cf451f2783a38b8e67a08958f0be2b0.tar.bz2
aports-376c27e55cf451f2783a38b8e67a08958f0be2b0.tar.xz
main/clamav: fix libclamav version
Diffstat (limited to 'main/clamav')
-rw-r--r--main/clamav/0001-libclamav-explicitly-use-top_srcdir-.git-dir.patch41
-rw-r--r--main/clamav/APKBUILD7
2 files changed, 46 insertions, 2 deletions
diff --git a/main/clamav/0001-libclamav-explicitly-use-top_srcdir-.git-dir.patch b/main/clamav/0001-libclamav-explicitly-use-top_srcdir-.git-dir.patch
new file mode 100644
index 0000000000..c180427726
--- /dev/null
+++ b/main/clamav/0001-libclamav-explicitly-use-top_srcdir-.git-dir.patch
@@ -0,0 +1,41 @@
+From 3e0878adc26b39ecd6c2bf74dad129ee8636fac9 Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@alpinelinux.org>
+Date: Fri, 16 Feb 2018 02:11:09 +0000
+Subject: [PATCH] libclamav: explicitly use top_srcdir .git dir
+
+This will prevent git from picking up a ref from parent git repository
+and setting this as libclamav REVISION/version.
+---
+ libclamav/Makefile.am | 2 +-
+ libclamav/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libclamav/Makefile.am b/libclamav/Makefile.am
+index 1c4c007c0..5d22b6483 100644
+--- a/libclamav/Makefile.am
++++ b/libclamav/Makefile.am
+@@ -616,7 +616,7 @@ version.h: version.h.tmp
+ version.h.tmp:
+ $(AM_V_GEN) test -f version.h || touch version.h;\
+ rm -f $@;\
+- REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
++ REVISION="$$(LANG=C git --git-dir "$(top_srcdir)"/.git describe --always 2>/dev/null || echo "exported")";\
+ if test "$$REVISION" = "exported"; then\
+ REVISION="";\
+ fi;\
+diff --git a/libclamav/Makefile.in b/libclamav/Makefile.in
+index 6e19dcd9e..acace3394 100644
+--- a/libclamav/Makefile.in
++++ b/libclamav/Makefile.in
+@@ -3777,7 +3777,7 @@ version.h: version.h.tmp
+ version.h.tmp:
+ $(AM_V_GEN) test -f version.h || touch version.h;\
+ rm -f $@;\
+- REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
++ REVISION="$$(LANG=C git --git-dir "$(top_srcdir)"/.git describe --always 2>/dev/null || echo "exported")";\
+ if test "$$REVISION" = "exported"; then\
+ REVISION="";\
+ fi;\
+--
+2.16.1
+
diff --git a/main/clamav/APKBUILD b/main/clamav/APKBUILD
index ca6e1aceea..028e83fc7d 100644
--- a/main/clamav/APKBUILD
+++ b/main/clamav/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=clamav
pkgver=0.99.3
-pkgrel=1
+pkgrel=2
pkgusers="clamav"
pkggroups="clamav"
pkgdesc="An anti-virus toolkit for UNIX eis-ng backport"
@@ -27,6 +27,8 @@ source="http://www.clamav.net/downloads/production/$pkgname-$pkgver.tar.gz
freshclam.confd
clamd.logrotate
freshclam.logrotate
+
+ 0001-libclamav-explicitly-use-top_srcdir-.git-dir.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -210,4 +212,5 @@ ed81be79bf9a25eec071312252121cc76c96838407377b75077bf94922055f1de99f327982ac4dcc
00daed8afb67a6e4a29893340246c8840cce970dd9103d26557ecdd26ef60b12551d2291c214fc657faaaa339484052079347411b0cad65e3a33ece56d57cf16 freshclam.initd
ba181fe1abaac7b898ccb40b0713455aa3c9d5e25ad21d687b6cac09b0105b9e376526e7c776a44636234d8db819709d8d6a6cc76119bc3e98b637b1a3f26c08 freshclam.confd
3ae493dd1610a819402c015f6b8c0f080f926b72dc43d2bded60030bf6a55040e4b88e0f64d3aae299dc1133d7e1b89855e7346b4665a64e8b82592f7b75cf6a clamd.logrotate
-30cff378bc28c76b795e00c92ae5ee623f3abe4a19bed61dd8403c96e72658bb02b7f040d26a6258104af754464d25ea7d9646918c4b47d2ba9a8cbf4687056c freshclam.logrotate"
+30cff378bc28c76b795e00c92ae5ee623f3abe4a19bed61dd8403c96e72658bb02b7f040d26a6258104af754464d25ea7d9646918c4b47d2ba9a8cbf4687056c freshclam.logrotate
+7eeac468d1e2bc6fde8d1e4cbe0b7fad646d41798fe860718bf0a8ed6026920222daae125804a58f8add02487bf9c9e72a618f87441b20782910668915c99a75 0001-libclamav-explicitly-use-top_srcdir-.git-dir.patch"