aboutsummaryrefslogtreecommitdiffstats
path: root/main/clamav
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-20 16:38:27 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-09-20 16:38:55 +0300
commit41cb787e4261b69ac73ad3b2f3256ec3fadefe8c (patch)
treeea05ffa67c51e49306c1076f7f5b993e3f9a5a0d /main/clamav
parentc46cd2811caa2f3bb6f3ddb7680551fcf7eb32ed (diff)
downloadaports-41cb787e4261b69ac73ad3b2f3256ec3fadefe8c.tar.bz2
aports-41cb787e4261b69ac73ad3b2f3256ec3fadefe8c.tar.xz
main/clamav: upstream now ships .conf.sample, fix packaging
Diffstat (limited to 'main/clamav')
-rw-r--r--main/clamav/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/clamav/APKBUILD b/main/clamav/APKBUILD
index 8e84012e69..529a9b73a5 100644
--- a/main/clamav/APKBUILD
+++ b/main/clamav/APKBUILD
@@ -59,7 +59,7 @@ package() {
-e "s:^\#\(NotifyClamd\).*:\1 /etc/clamav/clamd.conf:" \
-e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- "$pkgdir"/etc/clamav/freshclam.conf
+ "$pkgdir"/etc/clamav/freshclam.conf.sample
# set proper defaults
sed -i -e "s:^\(Example\):\# \1:" \
@@ -69,7 +69,7 @@ package() {
-e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
-e "s:^\#\(LogTime\).*:\1 yes:" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- "$pkgdir"/etc/clamav/clamd.conf
+ "$pkgdir"/etc/clamav/clamd.conf.sample
}
lib() {
@@ -100,7 +100,7 @@ freshclam() {
"$subpkgdir"/etc/clamav
mv "$pkgdir"/usr/bin/freshclam "$subpkgdir"/usr/bin || return 1
- mv "$pkgdir"/etc/clamav/freshclam.conf \
+ mv "$pkgdir"/etc/clamav/freshclam.conf.sample \
"$subpkgdir"/etc/clamav/ || return 1
install -d -m755 -o clamav -g clamav \
"$subpkgdir"/var/run/clamav \
@@ -162,7 +162,7 @@ daemon() {
"$subpkgdir"/usr/bin/ || return 1
mv "$pkgdir"/usr/bin/clamdscan \
"$subpkgdir"/usr/bin/ || return 1
- mv "$pkgdir"/etc/clamav/clamd.conf \
+ mv "$pkgdir"/etc/clamav/clamd.conf.sample \
"$subpkgdir"/etc/clamav/ || return 1
install -m755 -D "$srcdir"/clamd.initd \
"$subpkgdir"/etc/init.d/clamd || return 1