aboutsummaryrefslogtreecommitdiffstats
path: root/main/cmake
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-25 19:48:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-25 19:49:12 +0000
commit27a77843067942090619468d3a0db6229f879747 (patch)
tree2accb0daed185f69ff530c0482258ac1aca2364e /main/cmake
parentfbddf60466093de2bc3fc0d28dd37e631be62049 (diff)
downloadaports-27a77843067942090619468d3a0db6229f879747.tar.bz2
aports-27a77843067942090619468d3a0db6229f879747.tar.xz
main/cmake: use bundled jsoncpp to avoid circular dependency
Diffstat (limited to 'main/cmake')
-rw-r--r--main/cmake/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/cmake/APKBUILD b/main/cmake/APKBUILD
index d8e9eb9ee8..7e5f125b31 100644
--- a/main/cmake/APKBUILD
+++ b/main/cmake/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cmake
pkgver=3.11.1
-pkgrel=0
+pkgrel=1
pkgdesc="Cross-platform, open-source make system"
url="http://www.cmake.org"
arch="all"
license="BSD-3-Clause"
-makedepends="bzip2-dev curl-dev expat-dev jsoncpp-dev libarchive-dev
+makedepends="bzip2-dev curl-dev expat-dev libarchive-dev
libuv-dev ncurses-dev rhash-dev xz-dev zlib-dev"
options="!checkroot !check"
checkdepends="filel musl-utils"
@@ -33,12 +33,17 @@ _parallel_opt() {
build() {
cd "$builddir"
+ # jsoncpp needs cmake to build so to avoid recursive build
+ # dependency, we use the bundled version of jsoncpp.
+ # Do NOT remove --no-system-jsoncpp unless you consulted
+ # maintainer
./bootstrap \
--prefix=/usr \
--mandir=/share/man \
--datadir=/share/$pkgname \
--docdir=/share/doc/$pkgname \
--system-libs \
+ --no-system-jsoncpp \
$(_parallel_opt)
make
}