aboutsummaryrefslogtreecommitdiffstats
path: root/main/cmake
diff options
context:
space:
mode:
authorPelle Bo Regener <pboreg@mek.dtu.dk>2017-04-15 12:23:18 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-25 11:12:53 +0000
commita198b74f927429d74ae084e1f0a2558e45004c93 (patch)
tree8e203b52de839049db9ffc7c1345899462277ce0 /main/cmake
parent5655b77a222b892eafc6f544d19a7784ea6f9bdc (diff)
downloadaports-a198b74f927429d74ae084e1f0a2558e45004c93.tar.bz2
aports-a198b74f927429d74ae084e1f0a2558e45004c93.tar.xz
main/cmake: Improve APKBUILD, use bundled jsoncpp
Remove explicit `--system` flags, as `--system-libs` should do the trick. Also use the bundled `jsoncpp` again to allow Alpine's `jsoncpp` package to be built using cmake instead of scons (the latter being deprecated).
Diffstat (limited to 'main/cmake')
-rw-r--r--main/cmake/APKBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/main/cmake/APKBUILD b/main/cmake/APKBUILD
index 5e8e86ff7d..7f3a80f449 100644
--- a/main/cmake/APKBUILD
+++ b/main/cmake/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cmake
pkgver=3.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="CMake is a cross-platform open-source make system"
url="http://www.cmake.org"
arch="all"
license="CMake"
depends=
makedepends="ncurses-dev curl-dev expat-dev zlib-dev bzip2-dev libarchive-dev
- libuv-dev xz-dev rhash-dev jsoncpp-dev"
+ libuv-dev xz-dev rhash-dev"
subpackages="$pkgname-doc"
case $pkgver in
@@ -32,19 +32,14 @@ parallel_opt() {
build() {
cd "$builddir"
- # jsoncpp seems to need cmake to build so to avoid recursive build dep
- # we use the bundled
+ # jsoncpp needs cmake to build so to avoid recursive build
+ # dependency, we use the bundled version of jsoncpp
./bootstrap --prefix=/usr \
--mandir=/share/man \
--datadir=/share/$pkgname \
--docdir=/share/doc/$pkgname \
--system-libs \
- --system-curl \
- --system-expat \
- --system-zlib \
- --system-bzip2 \
- --system-liblzma \
- --system-libarchive \
+ --no-system-jsoncpp \
$(parallel_opt)
make || return 1