aboutsummaryrefslogtreecommitdiffstats
path: root/main/command-not-found
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-10-21 04:36:07 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-21 04:36:22 +0000
commit24a47bbe86bb0df8e62e9fa1a5e302cd7d808328 (patch)
treeea377349bd40039b75dccdf77b0d5014e7401e16 /main/command-not-found
parent0f39c852d32a8eed2f7a8ba46f5feccbcbb998c4 (diff)
downloadaports-24a47bbe86bb0df8e62e9fa1a5e302cd7d808328.tar.bz2
aports-24a47bbe86bb0df8e62e9fa1a5e302cd7d808328.tar.xz
main/command-not-found: new aport
Diffstat (limited to 'main/command-not-found')
-rw-r--r--main/command-not-found/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/command-not-found/APKBUILD b/main/command-not-found/APKBUILD
new file mode 100644
index 0000000000..732334d294
--- /dev/null
+++ b/main/command-not-found/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=command-not-found
+pkgver=0.1
+pkgrel=0
+pkgdesc="friendly command not found handling"
+url="https://github.com/kaniini/command-not-found"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends=""
+install=""
+subpackages="" # eventually $pkgname-zsh and others
+source="command-not-found-$pkgver.tar.gz::https://github.com/kaniini/command-not-found/archive/v$pkgver/command-not-found-$pkgver.tar.gz"
+builddir="$srcdir/command-not-found-$pkgver"
+options="!check" # no testsuite
+
+package() {
+ cd "$builddir"
+ install -d -D -m755 "$pkgdir"/usr/libexec "$pkgdir"/etc/profile.d/
+ install -m755 command-not-found.sh "$pkgdir"/usr/libexec/command-not-found
+ install -m755 profiles/command-not-found.ash "$pkgdir"/etc/profile.d/command-not-found.sh
+}
+
+sha512sums="aeb69e6fc5eaebe8c4f50772cfed0ea669ac5896afa8f734beeb16db844ceecd07a9f81e2a22dcd0024ec5ec437586fa2d8f2e529bb6836b47d5ca11a4bb5dbc command-not-found-0.1.tar.gz"