aboutsummaryrefslogtreecommitdiffstats
path: root/main/compiler-rt
diff options
context:
space:
mode:
authorEric Molitor <eric@molitor.org>2020-02-16 12:19:32 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-02-16 10:48:43 -0300
commit8b44ad2619302012d0a778b1df72c049bbca4115 (patch)
tree124a6016c760b028af00fc92787b510cba879d80 /main/compiler-rt
parentc58cd4138f31fd5ac4444302734229ada035aa29 (diff)
downloadaports-8b44ad2619302012d0a778b1df72c049bbca4115.tar.bz2
aports-8b44ad2619302012d0a778b1df72c049bbca4115.tar.xz
main/compiler-rt: Fix compiler-rt install location
Alpine currently installs compiler-rt into the following location. [DESTDIR]/lib/clang/[CLANG_VERSION] However, Clang expects compiler-rt to be located at a specific location. [DESTDIR]/lib/clang/[CLANG_VERSION]/lib/[OS] This results in clang on Alpine not being able to use compiler-rt. clang -rtlib=compiler-rt hello.c /usr/bin/ld: cannot find crtbeginS.o: No such file or directory /usr/bin/ld: cannot find /usr/lib/clang/9.0.0/lib/linux/libclang_rt.builtins-x86_64.a: No such file or directory /usr/bin/ld: cannot find /usr/lib/clang/9.0.0/lib/linux/libclang_rt.builtins-x86_64.a: No such file or directory /usr/bin/ld: cannot find crtendS.o: No such file or directory This change corrects the install location and allows clang to use compiler-rt as a runtime library via -rtlib=compiler-rt.
Diffstat (limited to 'main/compiler-rt')
-rw-r--r--main/compiler-rt/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/compiler-rt/APKBUILD b/main/compiler-rt/APKBUILD
index a95d294a4d..01fdc2d1ae 100644
--- a/main/compiler-rt/APKBUILD
+++ b/main/compiler-rt/APKBUILD
@@ -1,9 +1,10 @@
+# Contributor Eric Molitor <eric@molitor.org>
# Contributor Travis Tilley <ttilley@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=compiler-rt
# Note: Update together with llvm.
pkgver=9.0.1
-pkgrel=0
+pkgrel=1
_llvmver=${pkgver%%.*}
pkgdesc="LLVM compiler-rt runtime libraries"
arch="aarch64 armv7 x86 x86_64"
@@ -64,10 +65,10 @@ package() {
cd "$pkgdir"
- mkdir -p usr/lib/clang
+ mkdir -p usr/lib/clang/$pkgver/lib
case "$CARCH" in
ppc64le | s390x) ;;
- *) mv usr/lib/linux usr/lib/clang/$pkgver;;
+ *) mv usr/lib/linux usr/lib/clang/$pkgver/lib;;
esac
}