aboutsummaryrefslogtreecommitdiffstats
path: root/main/cppunit
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-08-28 13:13:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-28 22:55:29 +0000
commit02c365aa07d8e4b8f91b3cd437e142f15741e5b9 (patch)
treef226c4ed7fa3bd1cb3433a076d8393b42eb87af1 /main/cppunit
parent77e8f09231f6031903c87ecef18abe4fbc0bdc84 (diff)
downloadaports-02c365aa07d8e4b8f91b3cd437e142f15741e5b9.tar.bz2
aports-02c365aa07d8e4b8f91b3cd437e142f15741e5b9.tar.xz
main/cppunit: upgrade to 1.14, modernize and add check
Diffstat (limited to 'main/cppunit')
-rw-r--r--main/cppunit/APKBUILD42
1 files changed, 15 insertions, 27 deletions
diff --git a/main/cppunit/APKBUILD b/main/cppunit/APKBUILD
index 574c14d401..cbbf989aff 100644
--- a/main/cppunit/APKBUILD
+++ b/main/cppunit/APKBUILD
@@ -1,32 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cppunit
-pkgver=1.13.2
-pkgrel=1
+pkgver=1.14.0
+pkgrel=0
pkgdesc="C++ unit testing framework"
url="http://www.freedesktop.org/wiki/Software/cppunit/"
arch="all"
license="LGPL2+"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://dev-www.libreoffice.org/src/cppunit-$pkgver.tar.gz"
+source="http://dev-www.libreoffice.org/src/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/cppunit-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
LIBS="-ldl" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,16 +20,18 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="d1c6bdd5a76c66d2c38331e2d287bc01 cppunit-1.13.2.tar.gz"
-sha256sums="3f47d246e3346f2ba4d7c9e882db3ad9ebd3fcbd2e8b732f946e0e3eeb9f429f cppunit-1.13.2.tar.gz"
-sha512sums="8f4be569f321d577cec31931f49f4df143bc94e283605509b6ea50c60690aa91a2aed940e7eebd4b2413a4218f9a6c3978d312d8e587eab040283c6563846ecd cppunit-1.13.2.tar.gz"
+sha512sums="4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e cppunit-1.14.0.tar.gz"