aboutsummaryrefslogtreecommitdiffstats
path: root/main/cppunit
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-25 14:21:44 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-25 14:45:03 +0100
commitbfce05b9aa792b01641abad28ec25cd6428f7a31 (patch)
tree7a505032c1bda43f2bd1470d010d6a8fa9ad4557 /main/cppunit
parent6b647c8dea40b4e90402d4d0b8628c96e34106c3 (diff)
downloadaports-bfce05b9aa792b01641abad28ec25cd6428f7a31.tar.bz2
aports-bfce05b9aa792b01641abad28ec25cd6428f7a31.tar.xz
main/cppunit: upgrade to 1.15.0
Diffstat (limited to 'main/cppunit')
-rw-r--r--main/cppunit/APKBUILD15
-rw-r--r--main/cppunit/fix-Werror-deprecated-copy.patch30
2 files changed, 4 insertions, 41 deletions
diff --git a/main/cppunit/APKBUILD b/main/cppunit/APKBUILD
index 94fbe92729..a59c9d6ccd 100644
--- a/main/cppunit/APKBUILD
+++ b/main/cppunit/APKBUILD
@@ -1,19 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cppunit
-pkgver=1.14.0
-pkgrel=1
+pkgver=1.15.0
+pkgrel=0
pkgdesc="C++ unit testing framework"
url="http://www.freedesktop.org/wiki/Software/cppunit/"
arch="all"
license="LGPL-2.0-or-later"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://dev-www.libreoffice.org/src/$pkgname-$pkgver.tar.gz
- fix-Werror-deprecated-copy.patch"
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://dev-www.libreoffice.org/src/cppunit-$pkgver.tar.gz"
build() {
- cd "$builddir"
LIBS="-ldl" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,14 +22,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e cppunit-1.14.0.tar.gz
-000404d7b3318743f416d4d10ecd245935a5e1f4f0a43910eeeda152a0151855adffa8a70632abe0a76e24b408233e5d1f287eff2f174e60c65b2e5cfae66c34 fix-Werror-deprecated-copy.patch"
+sha512sums="2ee90c5317f9480020095896b38e470ab8a63ab9b695db479f1b37512570fed37a271c3259004c9ce92b4fb051d37e1aa3bae55ec30c80d97041c59d2a257810 cppunit-1.15.0.tar.gz"
diff --git a/main/cppunit/fix-Werror-deprecated-copy.patch b/main/cppunit/fix-Werror-deprecated-copy.patch
deleted file mode 100644
index 6866e93aeb..0000000000
--- a/main/cppunit/fix-Werror-deprecated-copy.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/examples/cppunittest/OrthodoxTest.h b/examples/cppunittest/OrthodoxTest.h
-index 8fc2a08..a2bc678 100644
---- a/examples/cppunittest/OrthodoxTest.h
-+++ b/examples/cppunittest/OrthodoxTest.h
-@@ -38,6 +38,8 @@ private:
- public:
- Value( int value =0 ) : m_value( value ) {}
-
-+ Value( const Value & ) = default;
-+
- Value& operator= ( const Value& v )
- {
- m_value = v.m_value;
-@@ -143,6 +145,8 @@ private:
- {
- return ValueBadCall( -1 - m_value );
- }
-+
-+ ValueBadCall &operator =( const ValueBadCall & ) = default;
- };
-
-
-@@ -161,6 +165,8 @@ private:
- ++m_value;
- return *this;
- }
-+
-+ ValueBadAssignment( const ValueBadAssignment & ) = default;
- };
-