aboutsummaryrefslogtreecommitdiffstats
path: root/main/cryptsetup
diff options
context:
space:
mode:
authorSamantha Baldwin <fuhsaz+alpine@cryptic.li>2015-08-06 11:15:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-06 11:18:23 +0000
commitd2d2b27323141a4cf039647fe1c6d632557a5967 (patch)
treeb8ba416760b0acb55a87c04b2068b5f96d59f580 /main/cryptsetup
parent80cf64e8eb93fc4277fd70a7c1bbb57307e93286 (diff)
downloadaports-d2d2b27323141a4cf039647fe1c6d632557a5967.tar.bz2
aports-d2d2b27323141a4cf039647fe1c6d632557a5967.tar.xz
main/cryptsetup: Replace blkid with findfs in init.d script
blkid -U does not work on default alpine.
Diffstat (limited to 'main/cryptsetup')
-rw-r--r--main/cryptsetup/APKBUILD8
-rw-r--r--main/cryptsetup/dmcrypt.initd3
2 files changed, 5 insertions, 6 deletions
diff --git a/main/cryptsetup/APKBUILD b/main/cryptsetup/APKBUILD
index a8c6a721e5..b1cd63ddb2 100644
--- a/main/cryptsetup/APKBUILD
+++ b/main/cryptsetup/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cryptsetup
pkgver=1.6.7
-pkgrel=0
+pkgrel=1
pkgdesc="Userspace setup tool for transparent encryption of block devices using the Linux 2.6 cryptoapi"
url="http://code.google.com/p/cryptsetup/"
arch="all"
@@ -62,12 +62,12 @@ libs() {
md5sums="1b1856113b9711385e47f07d9cbb9e1d cryptsetup-1.6.7.tar.gz
7d5c8727ea417cabe86df67a9de1de16 flush-stdout.patch
1369aeaed84e41c8d585695596a24bd6 dmcrypt.confd
-1cd8aea7f04bb9bc2c781b243e40d6b3 dmcrypt.initd"
+a9a478ee9b5612379326cd96354779b4 dmcrypt.initd"
sha256sums="22744badd2319c241726f916979121b436ed6755dcd0e1f5394b1787def85e57 cryptsetup-1.6.7.tar.gz
6ac335bb14ff2f90de00769be20da4c5527101fab6593259a4d87be84904ae67 flush-stdout.patch
0c30e081c0b8f879964ae49735f10b05a1d92f4f481042851958860945e13271 dmcrypt.confd
-0cc0a0e846d737c226877ccb3378af075f4b1bc40110333f577d84549306ac2e dmcrypt.initd"
+477107555f0bedd662ae8181428de5428122b64139d3033ec7b5c1c801238665 dmcrypt.initd"
sha512sums="82007a00a371cefee190b2a0ff1e555de5c8a12df7cdc621a0812d167331cf43d3a06c2f501e236275ab9b8a07dbd79c08122b46f22fc0a75cf4305cf0447477 cryptsetup-1.6.7.tar.gz
301e3e3da5a899e0a6f01f44fbf37bb6a3f5b6a4fb41243bae6d3b7aea747276e784626cd1b19721cc264652c10ae8c560c4d20094e33bb82fb2fae0160682c0 flush-stdout.patch
d04ae17d3708ef20ade7afb223d4ef19e1b6812e0be8f9499e37e9c71344568b42030d9dd8f6918a9bfb211a3a94b40a9354e3b32a009cb165e84508d0a5e14b dmcrypt.confd
-e321ed6b2f5606325928a493930bd2ac9212cfef9565fa01491be33896fa3f27e8e9e828ace1cbfabef997bdcfe2635e283dd2697a1e926dd524360bb7f53ac0 dmcrypt.initd"
+0f8ca37330dfe4584026277542db63eb31b3fe8060096e840be3b75ba8fb1e8bddff3212c0324dc15cf59a804b74f92f538fbedc8ec876c9c9ece4ab37f00bb0 dmcrypt.initd"
diff --git a/main/cryptsetup/dmcrypt.initd b/main/cryptsetup/dmcrypt.initd
index 6d81483538..900c94c3d9 100644
--- a/main/cryptsetup/dmcrypt.initd
+++ b/main/cryptsetup/dmcrypt.initd
@@ -40,8 +40,7 @@ dm_crypt_execute_dmcrypt() {
return
fi
if [ "x${source#UUID}" != "x${source}" ]; then
- source=${source#UUID=}
- source="$(blkid -U ${source})"
+ source="$(findfs ${source})"
fi
if [ -z "${source}" ] && [ ! -e "${source}" ] ; then
ewarn "source \"${source}\" for ${target} missing, skipping..."