aboutsummaryrefslogtreecommitdiffstats
path: root/main/cups
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-22 18:38:36 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-03-22 19:59:12 +0100
commit3ad19b6062ccf5bf9fc4f14ddb6f6ce9be69ddb7 (patch)
tree53e0bbe4699849b71f587887e5762e675c7eef09 /main/cups
parent81c37601feb78e9e50cb99fc306f40e1bb3e993a (diff)
downloadaports-3ad19b6062ccf5bf9fc4f14ddb6f6ce9be69ddb7.tar.bz2
aports-3ad19b6062ccf5bf9fc4f14ddb6f6ce9be69ddb7.tar.xz
main/cups: fix ppc64le break
There are some cases that the desktop file is not copied into $pkgdir. This change only runs 'sed' on this file if the file exists.
Diffstat (limited to 'main/cups')
-rw-r--r--main/cups/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/cups/APKBUILD b/main/cups/APKBUILD
index 2e18efe1ab..ed65e7b6c1 100644
--- a/main/cups/APKBUILD
+++ b/main/cups/APKBUILD
@@ -74,7 +74,10 @@ package() {
install -D -m644 ../cups.logrotate "$pkgdir"/etc/logrotate.d/cups
install -D -m755 ../cupsd.initd "$pkgdir"/etc/init.d/cupsd
- sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' "$pkgdir"/usr/share/applications/cups.desktop
+ if [ -e "$pkgdir"/usr/share/applications/cups.desktop ] ; then
+ sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' \
+ "$pkgdir"/usr/share/applications/cups.desktop
+ fi
find "$pkgdir"/usr/share/cups/model -name "*.ppd" | xargs gzip -n9f
}